FSESC Keep Frying from Normal Benchtop Use

I know FSESCs don’t have a great reputation but this is getting out of hand. I have now fried my 4th FSESC from normal benchtop testing. No motor connected. Literally just configuring some of the application settings for my DIY one wheel. Luckily I buy them with Amazon so I send it back and they send me a new one a few days later but it’s getting quite annoying.

I know I should buy a brandname VESC but I’m too cheap for that. Is there any reason this could be happening? It usually occurs 5-10 minutes into normal testing. I have the Flipsky anti-spark switch in line as well as a 30A fuse. This has happened to 2 4.20 FSESCs and 2 6.7 FSESCs.

I’ve turned off the phase filter in settings which I’ve heard is problematic. I am also updating my firmware when I first get it. Should I keep it at the stock firmware?

I’m thinking of going to the FSESC75/100. Anyone have any experience with it?

Save yourself the trouble and get a DV75 from makerx or a stormcore 100D.

DV75 is not too pricy as the Stormcore 100D is. But these will save you from agony.

1 Like

I appreciate the advice. The stormcore looks a bit pricy unless I was looking at the wrong thing. The Makerx looks like a solid option though.

I already ordered the FSESC 75/100 so I’m gonna give it a shot and if it blows I’ll just get another refund and go when the Makerx.

It is pricy. It’s over 400 USD. But you are getting quality.

Good luck with that esc. But do get the DV75. It’s quite solid. I have a DV6 and its been good to me for years now.

Shall do. My battery is 13S so nominal voltage of 48V but around 54V when charged. The old FSESCs I was using were rated up to 60V. Since they’re crappy ESCs it was probably lower so it’s likely a small voltage spike was frying it. Hopefully the 75V rated ESCs will work.

Any escs that rated at 60v or 12s are limited to that. 13s will have a high voltage spike that can last longer than a second and can fry the esc.

It happens. Lesson learned. Some unfortunately are pricy ones.

1 Like

This is the problem. 60V controllers only support 12S batteries.

This is a name, not a voltage. Like George is a name.

this is a voltage. And it’s actually 54.6V -ish.

I must be the outliar because I currently use 5 different FSESC’s and they all worked great. The website states 8V-60V but they also state very loudly that it is a 12S max. I run 10s and 12s batteries and have thousands of miles on each board from daily commute each year.

If you buy a 75100 I would open it and pot the capacitors. I rode mine about 300 miles before the capacitor leads broke from vibrations and started getting really sketch. Ive since repaired with new caps but i epoxy potted right after.

I think the 75100 will be my best bet. I’m not sure what you mean by “pot”. You mean put some epoxy over the cap joints to hold it better.

He meant add paddings as well as epoxy since the vibrations will break the caps. I forgot that was still a problem with the 75100s.

1 Like

I appreciate all the advice. Good thing Amazon doesn’t ask questions about returns…