GT2B constantly dropping signal and motor detection stopped working after connecting sensor wires [RESOLVED]

I broke my previous GT2B trying to install the Master Cho enclosure (antenna broke off while I was handleing the circuit board). My old GT2B worked perfectly, never had any drop outs, and always rode smoothly, I bought a new GT2B, and it’s the exact opposite, constantly dropping signal, and acceleration feels really jerky when i hold down the trigger. Doesn anybody have any idea how to fix this? Or did I just happen to get a faulty GT2B?

Hi ! I also broke my antenna mounting the Mad Munkey enclosure from @FLATLINEcustoms. It’s a pain to repair but it’s doable ! :slight_smile:

Otherwise, it’s the first time I hear about GT2B signal drops ! :neutral_face: Maybe a faulty one… Try to add a ferrite ring on the wire between receiver and (V)ESC. It could help sometimes.

1 Like

My GT2B was cutting out, and it was the connector from the ESC into the receiver wiggling around. Add some tape or glue and see if the signal still drops.

2 Likes

Now the motor detection doesnt work on any of my vescs. It says bad detection or detection failed. Now i cant figure out if its my vescs that are broken or my motors. All these problems started when i tried to connect my sensor wires. I only did a quick test run with the sensor wires connected, when my GT2B started dropping out, I disconnected my sensor wires to see if that would fix the problem. The motor detection still worked when i disconnected the sensor wires. Now it doesnt work at all with either of my vescs. Does anybody know what is going on with my board? This is so frustrating, ive tried everything to fix it, my board was running perfectly last week. PLEASE HELP!!!

Are you still in sensor or hybrid mode in the bldc, also if the 5v on your sensor motor is short it might have broke the drv or the receiver. Could you take some picture of your sensor wire right at the end of your motor and some of the sensor connector and resistor on the vesc

I had some mysterious issues with my VESC. Nothing worked. I re-flashed the firmware and all came back normally. Try it, it could fix your problem.

I don’t know which chip is the DRV, here are some pictures i took.

I guess I can give that a shot. Is it hard to do?

here is some video of how my board responds after I plug everything back in. The motor spins really slow.

Not at all, but double-check the firmware version matches to the Hardware version. There is a tutorial somewhere on the forum I guess.

The behaviour of your motor makes me feel that there is q problem with sensors. Are you in sensorless mode ?

Yes I am back in sensorless mode. And I have disconnected the sensor wires.

Ok. Try reflashing. DRV seems ok since you can spin the motor.

do i need a VESC USB Programmer STLinkv2 like this one to flash the firmware?

diy-electric-skateboard-kits-parts/vesc-usb-programmer-stlinkv2/

I don’t think it’s a firware issue, I think it’s a issue with, the servo cable or the sensor lead. but it look like de 5v short and broke the drv

When I type fault in the BLDC terminal i dont return any fault codes. It says FAULT_CODE_NONE

Could it be my motors that are broken?

It’ s not because you don’t see any faults that there not any problem with the drv.

But does it work in sensorless mode ?

No it doesnt work in sensorless mode. I only ran hybrid mode for a test run, and then switched back to sensorless. Motor detection was working for awhile when I switched back to sensorless, but then for some reason motor detection stopped working all together on both of my VESCs.

@torqueboards Hey dude, I bought my motors, VESC’s, and sensor wires from you. Any idea what is going on with my board? I just want to know what is broken so I can purchase the correct replacement parts.

No, you don’t. You just need the usual USB cable.

Like the FOC/BLDC switch issue, some parameters can stay “ghosts” and create issues on the VESC. That’s why often a reflash solve some troubles (I thought my VESC was died and reflash bringing it back to life :wink: )

Well I had a few issue with my old motor and sensor setup, the sensor cable was stretching up and make bad contact or even short with the ground