GT2B Issues with acceleration and braking

Whenever pull the trigger hard on my gt2b either to accelerate or brake with or without load the board stops responding for a few seconds and then works, however when i brake or accelerate in a short smooth motion it brakes and accelerate correctly what could be causing this, the first time i experienced this the board had a fully charged battery i havent rode it since so idk if it has to do with fully charged batteries being a cause, im using a gt2b with vesc and 5s lipos wired to 10s the lipos are 18.5v 4000 mah 15c

sounds like you need to look at the VESC errors. Realtime logging and the faults command line.

my guess is you are getting an ABS error on braking and overvoltage error on hard acceleration. I had similar issues when testing 12s and fixed by adjusting the settings. IIRC i’d get a couple blinks of one of the LEDs (red i think) and it would be non responsive for 1-2 seconds then reconnect and respond.

Hook up your VESC to BLDC and give us some screenshots.

yep its giving me a couple of blinking red light when i do it the way i explained, whenever i accelerate gently it shows yellow lights but then goes red when i do it hard… I’ll give screenshots in a bit im not near my pc atm

11 posts were split to a new topic: Throttle issue with GT2B

It could be over voltage you can set your max voltage to 57v. It doesn’t sound like a remote issue but vesc issue

Yeah sounds exactly like my issue. Adjusted both my ABS and voltage settings and fixed. You’ll probably see ABS overvoltage error when braking and another over voltage error accelerating.

so yeah its still doing the same and you are correct @sl33py it gives an overvolatage error what do you need screenshots of???

im using an enertion vesc with a 200kv chaka motor and two 5s 18.5 v 4000mah 15c batteries

You are having the max current ramp step error, described here:

Enertion seems to have sent out a ton of VESC with that error.

Also, better set the value of the “max input voltage” in the motor tab back to the default value of 57V (it’s 42V currently, which might kick in if you are having voltage spikes).

hmm ill be sure to update my vesc then any other tips???

Ive got the same issue but with a vesc (I got last week) from ?