Gt2b not working

Hey guys,

I need some help concerning my g2tb. I setup up everything. Motor detection worked. The red light on my gt2b reciever indicates that it is connected, but when I go to settings and select ppm, current no reverse with brake and tick display it stays at 50 %. It doesn’t do anything when I push full throttle or reverse. I hope somebody can help


do you have the PPM cable from the VESC plugged into the receiver in the correct spot and orientation?

it needs to be in channel 2, with the negative wire on the 3 pin cable furthest to the edge of the receiver.

Even if you have it in channel 1 or 3 (or if the 3 pin connector is in backwards) the receiver will still turn on and connect, it just won’t be able to transmit the information to the VESC.

Did you already bind the TX with the RX?

Did both. Still doesn’t work.

I have to bind everythime I turn the board on. Does this have to do with anything?

That’s definitely not normal. Do you mean you have to use a binding jumper every time, and go through the whole process? If so, that sounds like a hardware issue to me.

It works. Thanks for the help

What’s you end up doing?

Glad it’s solved!

The order in which you set up your rx und TX is very important. I missed one step and so I didn’t get any connection

1 Like

can you explain this a little better im going trhu tha same thing right now

Hey bud, glad you got yours to work. Would you mind sharing with the forum what you ended up doing to fix it ? Forums only work if its give and take

Hey, sorry I was on vacations. Will upload the whole deck soon. @Pablo_702. Just follow the steps from this video step by step

Hahaha thats the same video i watched to get it goin

I followed that video, but when I restart the vesc, the reciever starts blinking again. Anyone could help me? I don’t know what else I can try. Thanks

Did you configure the ppm settings?