Have I broken it?

Long story short, my board was working fine until my battery died (wouldn’t charge), fast forward 2 months and I got a new battery, plugged her in and one of my VESCs from esk8.de isn’t responding. Its just flashing red three times over and over again, tried checking for faults in the terminal but nothing, it will detect the motor but can’t set it up in bldc, foc, sensored, sensorless, any of the combination, I assume that I’ve got a DVR error but I have no idea how this would have happened, if anyone could shed some light on my issue and how it would have come about it would be much appreciated. Thanks, and break it to me easy :broken_heart:

1 Like


1 Like

Oh no, bringing in the big guns

Was there a spark when you plugged in the battery?

1 Like

Nope, no spark. The other vesc powered up nicely

Have you checked the terminal for fault codes in the Vesc tool?

Also does the Vesc flash red when you hit the throttle only?

If the red led flashes repeatedly and shows no fault in the terminal, most likely your “minimum batt” voltage setting is something else than 8V

What is the input voltage you are supplying?

Probably not related to your issue but if you are running Can bus make sure to connect both vescs simultaneously or you can fry the can chips

When I say I checked for faults I mean I typed in ‘faults’ and it returned that there were no faults since start up, is there another way?

And I can’t try the throttle because when I powered them up I updated the firmware on the so whipped their values. I did note that the flashing was happening before and after the firmware update

I’m giving it power from my 10s pack, outputting 38v currently

Yeah I am using can but I haven’t touched the can cable at all, I even wiped the vescs as I wanted to change the battery maximums and stuff

what you mean with it? you updated FW on the faulty vesc?

this one too. what you mean with “wiped”. you deleted stock settings?

Usually the red light has to be flashing for the fault code to show. You have to induce the failure during fault detection basicly.

I updated the firmware on both of the vescs, red light was flashing before and after the update. When i mean wiped I mean I updated the firmware so it got rid of my previous settings, is that not how it works?

It starts flashing as soon as it is powered on, I tried powering off the vesc then plugging the vesc into my pc then powering it up but still didn’t get anything in the terminal

Power everything on, than try to start a motor detection which will fail and than have a look in the terminal if faults are written.

When you say motor detection do you mean connecting it to the vesc tool?

‎ Yes.

Three red lights flashing usually means a drv fault. I have a few like that and none of them connect to the vesc tool.

1 Like

It could be the voltage regulator on the vesc that is dead. You can check it with a multimeter.