Have I focked my FOCBOXs?

Hi folks,

I hate to post another ‘why do my VESCs not work’ post, but I was really just after some confirmation and maybe a clue as to wether or not they are toast or can be fixed. I’ve read posts extensively but can’t find anything to match.

Scenario: I finally got my eMTB spinning yesterday (see post here) and couldn’t wait to take it for a ride today. In my haste I took it out pretty much just with the batteries and wires held down with tape and only intended to take it round the block but got carried away and hit a few speed bumps, pulled a few spins, etc! Anyways, on the way back I only had half power and when I got home I realised that only wheel was spinning. On inspection I noticed that one of the XT60 connectors into the FOCBOX had come out so without thinking I just plugged it back in. This created a small spark (more of a subtle pop) and then I realised that I hadn’t unplugged the loop key to make the connection. I tried the remote and had no power. Unplugged the loop key, plugged it back in but the FOCBOXes didn’t light up :fearful:

Since then I’ve tried all the tests I can think of; plugging one of the FBs into my esk8 setup, wiring up a smaller battery, plugging into BLDC with different power supplies (6s, 12s) and trying to detect. Both FBs seem to be completely dead. I’ve taken their clothes off and there is no obvious damage I can see:

Did I create a short and kill them? Is there a way to fix them or anyone I can send them to? I’m in Oz btw.

Any help would be gratefully received as I finally got to ride it today and it was absolutely bloody magical!

Thanks,

Dan

You blew the CAN tranceiver on both of them. This happens when one of them is not grounded anymore and still connected via CAN.

The fix here is replacing U401 on both units.

3 Likes

Could he simply pair them with a servo Y cable to bypass the canbus?

2 Likes

That’s what I did on my dual 4.12 vesc. Removed can transciever and split y servo. Best would be to send them in for repair

1 Like

Thanks for the info @Blasto - so would this prevent them from turning on at all? I’m currently getting nothing from them - no LEDs or anything and BLDC can’t detect them?

@L3chef any ideas who might be able to repair them? I’m in Oz but happy to post…

Im pretty sure 80% of eskate failures stem from this excitement to get going prematurely.

on the flipside, this seems like a pretty fragile flaw, especially when most people are running dual…

there should be like a failsafe ground connection between the two or something if this is a known thing…

all the more reason to: solder all the things! https://esk8content.nyc3.digitaloceanspaces.com/uploads/db2454/original/2X/7/7c2b8b63aea0ccd4bb8a7d03af06eb487aab32f6.jpg

9 Likes

Yeah I reckon you’d be spot on there. I knew I shouldn’t be going out too with things not properly secured but I just couldn’t help myself!! And I was literally gonna go up the road and turn around but one thing led to another… :blush: Ha…now I’m paying the price!! :confounded:

That would create a ground loop having a third wire as gnd… never tried tbh

If it’s any consolation, this would have happened w any vesc.

Talk to @JohnnyMeduse for repair

1 Like

Ok - cheers @Blasto

@JohnnyMeduse does this sound like something you’d be able to fix?

Appreciate all the help guys - I feel like such a dick!

The wizard who already is mentioned in this thread. Second option is to buy the parts yourself and solder them.

Lol, I’d love to say I’d give this a go but with my track record of things going bang I might leave this to a pro :wink: plus - I can hardly see half the chips on the board!

…out of morbid curiosity which chip is the U401? Scanned the boards but I’m guessing it’s not labelled as such?

The guy that is circled

1 Like

Aha…interesting. He’s actually one of the bigger dudes there. Are these chips easy to source?

Yes fairly easy, the hard part is removing and installing the new one properly

Part number SN65HVD232DR

2 Likes

Thanks buddy - I’ll look into it for sure - what’s the worst that could happen?!!

5 Likes

Is the ground you are talking about one of the CAN wires or something else? I’m sorry for the stupid question, but this seems like something I could screw up. Thanks Blasto.

Yes the CAN bus connector has 4 pins, 5V, CAN H, CAN L and gnd. But we are only using CAN H and CAN L at the moment.

I haven’t tried connecting the gnd wire also, so i don’t recommend doing it at the moment before it is properly tested

1 Like

So I’m really toying with the idea of trying to unsolder/solder these chips myself. @JohnnyMeduse offers a fair price for repairing VESCs but the postage to the US and back is a killer so I want to at least explore the idea. After all - this is a DIY forum! :wink:

I’ve had a look for the chips and I can find stacks of VP232 (keyword searching: SN65HVD232DR) but the chips themselves all seem to have different numbers/characters on the chip. Can anyone tell me what the ‘62M’ AHEC on the chip refers to? Do I need to match this or just ensure the ‘M’ is within a similar range?

This is the closest I can find here at 66M

Or this which has a more apt description:

Or is all of this a red herring and will any SN65HVD232DR or VP232 work?

Thank you

Dan

1 Like

Thank you to all the guys who contributed on this thread - I’ve managed to remove the fried can bus chips and the FOCBOXs have sprung back to life!! Gonna use a split ppm cable now rather than can bus so I’ll be back on the road!! Still not sure if vescs are right for my build but I’ll secure them properly this time and do some proper testing.

6 Likes

tat is sick brohan, good job on the mcguyver!