HELP - Can’t control my VESC with PPM or UART anymore

After recieving my new module for the photon I finally decided to install it… little I knew i should have not ! Now i tried 3 different remotes and nothing works. I typed faults looking for errors Tried with and without CANbus With PPM and UART I just can’t get the motors to spin and i can’t see any pulsewidth displayed on the BLDC tool

Please help me I have a group ride in a few hours it’s the first day of sun since decades !


That sucks! I am sorry for that. I hope someone can help you asap.

Otherwise one thing you can try is upgrade to the 3. Firmware. Either the normal one or Ackmaniac ( I am using the latest one). Then use VESC tool instead of BLDC tool for configuration. Maybe it will work out.

1 Like

I ll try that, i have no other choice so…

If you never use it and needs help just let me know. I did it 2 days ago

But i m not sure the 3 firmware is supported by the photon

You should check inside thier thread. I mean is the most advance one, it should be able to. Otherwise it worth a try and you can use another remote for today.

I m not sure about how to upgrade my vesc either

that I can help I did it 2 days ago…it’s all inside the VESC tool

What vesc are you using? your erpm limit seems way too high.

FOCBOX I let the erpm how it was can’t remember the limits

There’s no vesc tool for mac…

max 60.000 min -60.000 Although focbox is known to handle more than that. I doubt you’ll exceed 60k with that motor of yours.

Ackmaniac yes download the ESC tool folder. Inside one is for Windows the other for mac.

don’t upgrade. i’ve heard nothing but problems about 3.xx. reflash the vesc with your current fw. in the firmware tab of the bldc tool. redo all your settings and give it a shot.

btw erpm should be set to 60k just to be safe, also uncheck “limit erpm with negative torque”

1 Like

please use commas lol.

60.000 is much different than 60,000

God Photon pisses me off so hard, nothing but problems with it since i have it… i won’t struggle much more if i can’t make it work i ll ressell i have lost enough time with this shit already…

1 Like

Thanks i ll do that now

1 Like

The message still comes across the same, no?

make sure you choose 412 in the firmware files, you’ll know what i’m talking about when you get to it

1 Like

it took me a few times reading it to realize you meant 60000 instead of 60