Help! issues with 6374 motor on foc(updated with video and pictures)

I have issues setting up my focbox(one of them), it will fail if I run the default parameters but If I change the first parameter (I:) that is default to 5 and I increase that to 10+ it will run the detection and get valid values.

However when I get to the next part after that - running sensor detection for hall sensors - it will now say “Bad FOC Hall Detection Result Received” - I tried going changing the prior values during foc detection to 15A on “I:” parameter but not much else.

Don’t dare to try anything else but decided it was better the hear here on the forum before I risk destroying something.

I checked hall sensor cables and also I use an adapter to make it fit to Foxbox connector and its an adapter from But as far as I saw it was in the correct order. Will supply pictures down below to show. Also my setup is dual focbox - 6374 Torqueboards motor, 10s4p 30Q, Not connected by can. And bluetooth Metr module.

PS. The color swap from adapter to Focbox so don’t get confused and use the adapter image as reference to what color goes to what.

@torqueboards tagging you here because here are some pictures you asked for in support :slight_smile:

IMG_2796 IMG_2797 IMG_2802 IMG_2803 IMG_2812 IMG_2813IMG_2847 IMG_2852 IMG_2855

Worth to mention I tried my other motor which went through fine, even swapped focboxes and issues still there on the problematic motor and no issues on other.

Then you need to change the motor, or if you can change the sensors and sensor wiring loom.

Thanks for reply @Eboosted . It has troubles in sensorless aswell. It requires 10-15a in parameters to just spin to do motor detection. I checked solder joints, and motor is barely used. Its magnets came lovar after just a couple km then it was idle for a while and got replacement magnets from @torqueboards and they are replaced and works fine but since then its had this issue aswell

@Guacamoleface I’ll PM you

@Guacamoleface have you try to mesure it 2 time in a row? If it doesn’t work firt time try it again without changing anything.

Are those the default setting (current and voltage) ?

Yeah I tried a couple Times. Default for the motor detection yeah