Starting Tips | Ask Questions | Introductions | Categories

[HELP] Vesc Tool developer options

Hi,

Today all of a sudden my Slave Vesc went into OVER_TEMP_FET. I’m reading 120 degree Celsius and am not able to run the vesc anymore because I’m hitting the cutoff. In Vesc Tool you cannot go over 120 degree and since I am idling at 120-130 atm I cannot even do BLDC or FOC motor setup. In developer mode you can overwrite the limits, so I’m planning to just overwrite them and try to work with this. Never ever hit the cutoff Temp of the vesc so I’m pretty safe of running it this way with my settings.

The thermistor is reading 9800 Ohms. Reflashed the firmware Used Vesc Tool and BLDC Tool Vesc from Esk8.de. Less than a year old. 4.12 VESC

Somoene could help me fix my Vesc or helps me with a looparound for the Vesc Tool? I don’t manage to write these new limits which I write in the developer mode.

If you think your VESC is broken, you should get it fixed, not just override the firmware values. Vedder did select that number for a reason and not make it easy to override.

Depending on where you are located, the drv wizard @JohnnyMeduse should be able to help you if you can’t find someone locally.

1 Like

The Termistor seem alright, but maybe you could look into R2 to see if it is 10k (it should not give you 10k but around 8 if I remember correctly)

3 Likes

A french guy has the same issue after a run under wet conditions, same value in VESC Tool (around 120°C). We think that water made a short between MOSFET and R1 (measured at 0.5Ohm).

Check the resistance as @JohnnyMeduse suggested. Changing a single SMD resistance is not such a big deal if you do it carefully.

1 Like

Located in EU Belgium ,

R2 is 9kOhm

@Pimousse did you find a fix ? This could be true in my case aswell. Eu is pretty wet at the moment. Try to cover my vescs with shrink tube and glue gun as much as possible but always a chance water gets in.

So If I understand correctly my Vesc has a short over the thermistor. The thermistor isn’t broken because it still reads 8-9 kOhm. Should I try to remove the thermistor and check if there is something shorting the thermistor underneath ?

Thanks

one extra thing I notice is that my Motor Temp ( no temp sensor installed) is reading -80 degree Celsius. Don’t know if this is a correct value.

If you don’t have motor temp sensor connected, it’s normal that you get -80. On VESC Tool, displaying live value, is the temperature a steady line or does it moe a bit (in other words, is there any “life” on the signal) ?

If the thermistor is 8-9k, you should have something like your ambiant temperature (I hope it’s not the ADC which dies…).

Check the pictures of measures on respectively R2 and R1 of the French guy :

Can somoene explain me how I can overwrite the settings in developer mode in the new vesc tool? , If I would like to go the path of overwriting the max values

image

Use the “no limits” FW (available if you display non-standard FW in the list).

1 Like

.I read your thread on the ESK.FR forum, The guy is going to buy a new thermistor. But this will not resolve the problem since the values is stil good… The problem is that the pcb shorted somewhere… no?

He DOES have a fried thermistor (R1) which is 0.5k instead of around 10k (see second picture here).

I just uploaded the new firmware default_with_no_hw_limits. But this only let’s me change the current above 100A for Motor max , etc but not the Mosfet Temp. When I go into the “parameter editor MCConfig” under developer, I can change the l_temp_fet_start and l_temp_fet_end. I can save this as a XML file but how can I insert this into the vesc tool? Regards

FYI, the french guy (@Toleg , don’t know why I didn’t mention him before :wink: ) solved his OVER_TEMP issue by changing R1 resistor (like a master). I would not recommend to overpass the temperature limit as it may result in simply disable the temperature protection and thus fry your VESC under load.

But my r1 resistor is Reading 8-9kOhm… And I have never hit the max temp restriction with my current setup

If R2 and R1 are ok, I’m afraid that your issue comes from a dead ADC on the MCU… :neutral_face:

hi, i’m the guy with the problem :slight_smile: Can you send a screen capture of your temparature live feed on vesc tool ? Are your mosfet hot (when you touche them) even when your have just your vesc power on ?

I fixed the problem ! I removed the R1 resistor, and it works now without a temperature reading. Should try to find a new thermistor tho

https://www.mouser.fr/productdetail/81-ncp18xh103f03rb

you have a spare one? or did you buy just one?

Have a few spare, can send you one. PM :slight_smile: