Help with dual vesc setup

So got the board built currently connected to bldc tool can only get one motor to spin,both vesc’s have power motor dection works on both motors. My settings are set for master as follows Controller Id 0 PPM and UART Send status over can disabled “not ticked” Mutiple esc over can enabled "ticked settings for slave is setup as follows Controller id 1 PPM and UART Send status over can enabled “ticked” Mutiple esc over can disabled “not ticked” If I tick can fwd and select id 1 “slave” and go to realtime data and activate sampling I get a still graph “not moving” is this normal? It begins to move if I connect back to master! Any suggestions


Im not an expert but I think that the master should be id 0, so the :

Should be ticked.

And the id 1 not ticked. And can I see how you have connected it?

Yeah the master is set to id 0 and I thought that send status over can was supposed to be ticked on the slave to receive signal and Mutiple esc over can ticked on the master to send signal. Anyway tried to switch with the send status over can enabled on master and not the slave no luck! Also tried switching the Mutiple esc over can from master to slave no luck! What did you want to see the conections of?

The wiring of the VESC with Dual setup, the two wires that goes on the CAN bus. Have the Multiple ESC on and send over can too on the id 0

Done that id 0 that’s the master now have them both on what about the slave id 1

Let me check my dual setup brb

1 Like

What is your rate(hz) on Send Status Over Can?

500 10 characters

On the ID 1 I have the same thing as the ID 0 but I havent Send Status checked on id 1 nor in PPM in control mode disabled

The problem is that you have selected PPM and UART and the slave VESC. Set it to None at the Slave.PPM should only be active at the Master.

So Mutiple esc over can ticked on both master and slave and send status over can only ticked on master that’s what I now have setup no luck

Like @Ackmaniac said, on the Slave set the App to No app

Now have that done still nothing Does your graph move on realtime data when you test canbus connection via can fwd and selecting id of slave vesc

I read in a thread from @onloop that ppm should be activated on both anyway it’s just on the master at the minute still no joy

You have to select “No app”. Then write the configuration. Then reboot the Vesc. (Press the reboot button or switch off the power and switch it back on) Without a reboot the Application switch doesn’t work.

And if it is still not working then please post screenshots of the General and PPM Tab of the Master and Slave.

Yeah I did that selected no app on slave write configuration turned off and on still nothing will take some pictures

These first two pictures are master settings for app general and ppm

Same again but for slave