HM10 module not seen

Sooo got my hm10 module hooked up to my master focbox, everything is plugged in right and baud rate is set to 9600. I’ve also tried 115200. The red light is blinking (as in to indicate discovery?) My phone just wont see it in ackmaniacs app and the metr app. My phone is a samsung s8. Any insights are appreciated.

Make sure you have UART + PPM selected.

What version of Android are you running? Oreo won’t work with generic (clone) modules.

Gotcha, probably the module then, could you point me in the direction of one that would work on Oreo?

Are the TX/RX (HM10) and RX/TX (FOCBOX) connected correctly to one another?

Yeah its all set up right, it was just a cheap module i had laying around.

If the red light is flashing and your phone can’t see it, something is wrong with the module->phone connection. Try to find the module in the bluetooth part of your phone settings, ie don’t use the apps.

Did that, no dice. Its gotta be what @SeanHacker said.

If your using Android 8 it most likely will not see the hm-10 module, Bluetooth standards have changed in 8.

An hm-10 will never work with Metr. You have to have the Metr module to use the Metr app. It’s worth it though, I’ve got 2.


Would the firmware on Focbox affect UART transmission? Having similar problem.

I would disconnect the tx/RX pins, they aren’t relevant to your phone being able to see the bluetooth device. TRy and see if you can pair with it using a laptop. If you can’t even see the bluetooth device, the focbox connection side of things is irrelevant.

Try turning on the locaton services

UPDATE: Tried on an older android phone without Oreo. Picked it up just fine. I appreciate the insights, thanks everyone.