Starting Tips | Ask Questions | Introductions | Categories

How to reduce torque/acceleration on VESC?

After endless hours of reading this forum and tinkering I have finally managed to get my dual motor Eboard up and running. I have limited the top speed successfully (it was insane for a beginner) but I cannot get it to accelerate slower it just goes straight to top speed and I almost fall off everytime. I have played around with “Soft RPM Limit” settings which made a tiny bit of difference but it still takes off like a rocket. I guess theres other settings im not aware of that need to be adjusted. I wanted a 12s battery for the size and torque (big hills where I live) but this is ridiculous haha so any and all help would be most welcome as im out of ideas and cant find the same issue elsewhere in the forum.

My setup is x2 170KV Motors x2 VESC (Master and slave) 12s Lithum Ion Battery

VESC Settings


you can limit motor amperage, but maybe then it will be not enough powerful on the hills.
maybe you can try to adjust the throttle curve Extended BLDC-TOOL with Watt Control Mode, PPM Cruise Control, individual Throttle-Curve and Android App

1 Like

ok, ill give it a go in a little while and post my results here.

Post Screenshots of your settings for the motor and we can help you. More or less there are 2 parameters to control that. Motor max controls the power especially at lower speed and battery max at the higher speed and overall the total power.
But I recommend my modded firmware, because then you could define the throttle curve to make it soft at the lower throttle range and a beast at the higher throttle range.

1 Like

Guess you could go to 40A motor max at the begining. That’s what I did, each 3 days going up 10 A until you reached the top. Then you will be used to the punch.


Yes I will, I just read the other thread to figure it out and Im very impressed with what youve done. I have spent the last 5 hours in some kind of BLDC dream :laughing: staring at my computer but I wont stop until my “Pegasus” is born :grin: Ill keep you guys updated

Ok so… I got @Ackmaniac s modded BLDC tool up and running but now I need to flash the VESCs with his firmware because Im doing this with dual motors do I jus need to flash the “Master” motor or do both of them individually?

Definitely both.

1 Like

12s voltage = lots of torque and fast acceleration.
You might be able to improve your situation with a better controller.
So, what controller are you using?

1 Like

So ive managed to things up and running again with new firmware. After downloading the Modified BLDC tool

AND downloading the firmware flash file (.bin file) from the same place. I loaded up the Modded BLDC Tool and uploaded the new firmware like so…

After getting the green message “Firmware 2.52” I repeated the process on my slave VESC. I re’entered my values again and setup up the Master slave combo anew and there we have it almost done. Now all thats left is more tinkering with the throttle curve graph until I can make this 12s accelerate in a more controlled manner. Again if someone can help with graph values it will be appreciated … Im going to be making a small donation to @Ackmaniacs PayPal to thank him for his work (and help) and if anyone else benefits from this you can donate via the link in his thread!

Im using the the Winning controller and the throttle is a bit short, I would go for a Nano X but the price with shipping (to Chile) didnt really make sense.

First of all i can recommend this setup for the throttle curve. For the brakes you have to find out yourself what would be nice. If you think they are to powerfull at the beginning then lower them a bit. If they are too weak then raise them a bit.

This setup reduces the power output to

12% at 25 % throttle instead of 25 %. So the power is more or less 50% compared to normal.

30% at 50 % throttle instead of 50 %. So the power is more or less 60% compared to normal.

60% at 75 % throttle instead of 75 %. So the power is more or less 80% compared to normal.

And at full throttle it is full power.


I would recommend the Mini remote.
It’s a trigger 2.4 ghz and offers excellent control and dependability.

1 Like

Not sure what happened but after entering the new values my controller settings are all messed up I have also lost my dual motor config (its back to single motor) ???

Because you forgot to read the settings first before you update them. Maybe you pressed the read default accidentally.

1 Like

:open_mouth: haha… will I need to reflash the firmware? because now I cannot get the controller to reconnect

Are you sure that you modify the settings for the master? Because if you are in the setup for the slave then you would not be able to see a ppm signal.
If you connected the steering channel to the slave VESC to use the cruise control then you have to adjust the ppm parameters again for the slave vesc.

no cruise control I was using “Current No Reverse With Brake” now after trying to rebind the controller I have two solid red lights (normal) but the program doesnt pick up my controller

Choose the right USB port on the upper right and press the connect button. You are not connected.
You can see the connection status at the lower right.

then go to the general tab in apllications and choose PPM. then write the settings and press the reboot button. After that connect again and adjust your setup for the ppm. When you write the settings then you don’t need to reboot again.

1 Like

hahaha man Im sorry :blush::joy: i just panicked