Hub Motor Not Working After Reassembly....Wiring Issues

Hello All,

I recently decided to disassemble my hub motor budget board(Skatebolt). I did this because the board was beeping at me mid-ride and motors stopped working at 75% battery. I decided to unplug everything under the enclosure and then plug it back up for a reboot and educational purposes. However, as I was re-connecting the phase wires, one of the metal wire connectors on one of the phase wires snapped, so I had to strip back the wire enclosure, twist both wires together, and connect them with a wire cap connector(wire nut). Now, when I turned everything back on and applied acceleration, the hub motor with the phase wires leading into it that I “wire-nutted” back together works fine, but the other hub motor whose phase wires I did not snap and were reconnected in the same way I found them is not working. I am wondering if I confused the ESC or something by using the wire nut, and all the power is just going to that motor. I have attached a couple pictures to show what I did. The first picture shows the wires of the motor that works, and the second picture shows the wires of the motor which does not work. Any help or suggestions is greatly appreciated!


You haven’t confused it with that wire nut but you may have shorted the phase wiring to the other motor(the blue green yellow ones) They look very close together there in the top pic. First thing to do is unplug the battery connection which will probably be a yellow connector (xt60) with red and black wiring. (Hope I’m not being patronising here my friend but you seem new to this) Make sure the insulating covers are back on the motor wires. Try Removing the sensor wires to both motors. They are the thin red yellow blue green black wires coming from the motors with the white connectors cbfcc4de3369c987a616f86972339420d990a28c_1_690x335_LI Plug the battery back in and give it a go. If the motor still doesn’t turn then you have most probably fried the esc but most of the time when those esc’s fail they fail on both motors so its a bit strange.
Can you take a pic of the whole esc for me?

Hi Dareno,

No luck. I did as you said and tried without the sensor wires and still had the same problem. I will add that when I turn the board and try to free-spin both wheels with my hand, the motor that does not work has a lot more resistance to it. It feels similar to screwing on a gas cap or medicine bottle top where there is resistance in clicks, if that makes sense. It only has this resistance to it though when the board is on. The other wheel free spins fine. Therefore, I do not believe I fried the esc…at least hopefully not, but it does feel like the motor is stuck somehow. Here are pictures of the esc. Top one is a close up with the board off, and the bottom picture shows the board on, with the one motor spinning. Also, working on uploading a video. Thank you for helping, I greatly appreciate it.



Can you get a closer shot of the esc? Need to see more details on it.

I had some Genesis hubs that did the same thing but both motors. I ended up taking the hubs apart, cleaned the inside, did a very light sanding to remove imperfections, put back together and they were good to go. Not saying it will fix it but its worth a try.

If you have a voltmeter, check voltage and continuity on every wire. Wait! Have you tried flipping the motors? Meaning wire the problem hub to the working phase wires. If it spins, its most likely the esc. If it doesn’t then you’re looking at new hubs.

What is the not working hub doing, does it stutters or makes strange noises when accelerating?

Not trying be an ass or anything but he describes everything in his previous posts…

He just says they are not working, but not in which way, that’s why I was asking.

You sure about that?

And now that I read that again, @dareno, could it be stuck in brake mode? Like its shortex out to have constant brake on?

Thanks for the advice. I’m going to try that tomorrow when I have some free time.

1 Like

It does nothing, makes no noises. The only thing noticeable is the resistance when trying to free spin it.

You definitely disconnected the sensors? It sounds like a sensor issue to me. Especially with the motor resisting when on. Spins freely when off?
You could try to swap the motors over but don’t connect the bad one to the esc just the good one to the bad side. That way you isolate the motor issue from the esc. You are much less likely to hurt a motor with an esc than you are to hurt an esc with a motor. At least then you know the speed controller is cool. If you get the same issue then your esc is toast. If you don’t then there is an issue with the motor. Again though its a strange issue with that set up. Those duals fail completely usually not side by side in my experience. Aint diy fun??:roll_eyes:

Maybe he confused the sensor plugs, to try swopping them might solve it.

I asked him to disconnect completely so that shouldn’t be an issue. Those controllers work fine without sensors. @jackgr83 whats this? c97858a889ec1da39cc69912fbfb56cc2e283b29_LI

Yeah that put me off too. And usually when having them swopped it stutters. The colors from the phase wires are matching too, but for me it looks like they are shorted in some way.

Those two white wires connect from the esc to two separate LED lights on the outside of the enclosure which you can see on either side of the motor cables in the picture. One of them actually broke, but I would not think that would affect the motor, just the lights.

I am going to try this tomorrow, and I did definitely disconnect the sensors.

1 Like

@goldrabe Actually I did switch the sensors, and then the working motor did that stuttering, but the other motor still did nothing.

Yeah I think the best advice is what @dareno said, trying to swop the motors. I had three ESC’S of this kind some with matching phase wire colors some with non matching. I wired them in maybe all possible ways but when wrongly wired they always made some kind of noise or where stuttering. I hope you can solve it without having to buy new parts!