Hub motor whirls but won't accelerate, problems with vesc motor setup wizard

Hello! I am attempting to build an electric skateboard but running into some issues with my duo hub motor

Heres the components:

  • puiada duo hub motors
  • Flipsky vx1 remote
  • Tenka vesc
  • 2 5s lipo batteries

When trying to use the motor setup wizard on my vesc tool, a “flux lunux detection error” message kept coming up. The other forums recommended checking the connection + soldering of the motor wires, but they all connect without touching. I finished the “input setup”, but the controller can only break and when I try to accelerate a whirling sound happens like the wheel is trying to spin but somethings off. This issue is the same in both hub motors. The first time I attempted to use the motor setup wizard the test did work, and the wheels moved, but they stopped working again when I tried to calibrate the forward vs reverse section. Now both calibrations dont work. Ive tried resetting the vesc tool, resetting the vesc, and switching the wire colors/ re-soldering without any luck. I currently am running sensorless since I don’t have a 5pin hall to 6pin connector, yet it worked sensorless the first time. The settings are currently in FOC mode. Any clue about what might be wrong?

Thanks sososo much in advance

1 Like

So you haven’t ran motor detection successfully yet?

yeah the error message keeps popping up

Are you using a computer or phone?

I’m using my Computer

1 Like

In the menu wizard in the desktop app you have also ‘setup other motors’ maybe than one works ?

But probably it use’s the same method as in the other wizard.

And otherwise I would try BLDC first, you can choose that in the same wizard. Of course it’s not so nice as FOC, but then at least you can skate/drive.

And do you see some error code’s in the terminal ?

yeah it keeps saying an FOC error even though i’m running it in BLDC. Might be a hub motor issue since I got a knockoff brand…