I might have "bricked" my esc. Help?

Perform a full chip erase. Then flash the firmware you want. Connect to VESC Tool et flash the bootloader through it.

Then try to upload a new FW through VESC Tool.

Did you program them with ST-link utility?

You need to program a vesc6 bootloader at flash address 0x80E0000.

If you need, I can upload a short video of me doing this for one of my FSESC 6.6.

That would be great :slight_smile:

I’m moving forward with the physical part of the build in the meanwhile15594171560367442095420154358223 15594171848301040376096583839583 15594172066748941821636531436316


make sure BOTH devices have power and the nucleoboard is plugged into the computer before connecting ANYTHING.

make sure that the bootloader is programmed at flash address 0x080E0000 or you WILL corrupt the firmware.

Please let me know if you have any questions.

1 Like

i did exactly as i saw on your vid and ended up at ‘‘firmware on connected esc is too old please update using a programmer’’

and on vesc tool i get invalid serial com 10

might need to reflash the firmware as well then. Follow the exact same steps except instead of the bootloader file (which was 60_o_75.bin), select the desired firmware. You can find and download the firmware binaries here: https://github.com/vedderb/bldc/tree/master/build_all/60

Select default or default_no_hw_limits. ALSO, program this at flash start address 0x08000000 (this is set by default in st-link utility when programming new firmware images, so you should not have to change the value when programming the firmware after selecting it)

and i am no longer able to connect to it at all. it tells me it cant find the target

does the ESC still have both blue lights on? also check all the connections and restart ST-link utility.

did all that and still no :frowning: also now i can no longer connect to my slave it also tells me for some reason that the firmware is too old

The ESC still has both blue lights on, correct? Could you send me a picture of the connections?

IMG_20190601_173534556 IMG_20190601_172050693 IMG_20190601_173547129 IMG_20190601_173603222

Everything looks correct… maybe try unplugging the SWD connections, power cycling everything, then connecting the two back together, also restart st-link utility.

If that doesn’t work, then try connecting the NRST wire as well and see if it can connect under reset.

Also, I would highly recommend not doing this on top of batteries or other pieces of metal that can conduct…

ill try that last part as i already unplugged everything and restarted from scratch. even chnged the wires

can we speak on cam (fb messenger)? im back to the problem of old firmware

I’m also having this issue, but with a original Vesc 6 from Trampa. I’m making a build with two vesc 6’s that was working okay until I went to update the firmware. One worked flawlessly but the other one got its power disconnected in the process. Now I’m with one Vesc functional and the other one only with the blue light on, and I can’t connect to it with the usb port, which means it’s probably bricked.

I bought an ST Link V2 to connect to it, but it kept giving an “could not connect to target” error even after checking the wiring many times (Gnd - Gnd, Swclk - Clk, Swdio - Io). I tried connecting the St link to the working Vesc as well but I had the same problems, so It’s not an issue with the Vesc itself.

I also tried connecting one Vesc to the other and using “SWD Prog” through the vesc tool but it also gave target errors.

I’m pretty much out of hope, but I really don’t want to buy another Vesc. What am I doing wrong? Do I need to buy a Nucleo board?

I just went straight for a nucleo board as it was recommended by @Gamer43 it revived it like it was simply a bad cold :slight_smile:

1 Like

Really Hope you find a fix! Think I have simular problems!

Hi, sorry for the delay. As soon as the Nucleo Board arrived, I hooked it up with the rst pin, went into the ST Utility software and selected “Connect under reset”. After that, I finally was able to upload the bootloader and the FW. Still working to this day! Thanks for the help!

1 Like

Glad I could help somewhat. Ride on