I need help with my own built Mountainboard

Hello Esk8 Builders,

I recently build my own electric Mountainboard, according to the Patriot build from SkateMetric, see here:


After I finished everything up, it was hella fun driving this thing, it worked for about 2 hours drive time all in all. One day it was getting a little bit wet while driving with it (I build it so no moisture can get into the case), and during driving the torque of the board just went down and down to the point where it wasnt even able anymore to have enough torque to handle my body weight (altough this thing has a hella lot of power). Now I was trying to fix it but I really dont know whats wrong. When I let it sit in my room for a few weeks without using it and then try to use it again, it works with full power for like 2 minutes and then it gets down again to the point where it cant carry me anymore… Can somebody please tell me what part of my board is broken, I am really helpless about this right now.

Best regards, Wido

1 Like

Hi Wido!

On the VESC tool, what is the offset temp of your motors, and the offset temp of your ESC? It sounds like something is getting hot and the ESC automaticly reduce the power to avoid killing motor or chip. Did you try to touch motors or ESC?

1 Like

Hey Johnny,

First of all thanks for your quick response.

Yes I already tried touching the Esc straight afterwards and it doesnt seem to be too hot, Im not an expert tho so idk… I also kind of have struggles to put the Esc and the batteries in the case without it all being a little bit too tight maybe. They are huge batteries after all, but regarding to the build it should be fine… The motors are also fine, regarding the temperature at least. I also have a video showing off how I constantly almost full throttle it after a little drive and you can see the torque getting lower and lower to the point where it almost stops spinning. Dont get distracted by the not plugged in hall sensors, I forgot to plug them in when I recorded this, but I tried it afterwards with them plugged in and the result is the same.

Oops ok I just tried to upload it but it seems this Forum doenst support videos, thats a bummer. Can I send something else which could help you identify the problem??

Best regards, Wido

1 Like

In the VESC tool, under the Motor settings (on the left) there is a “general” button. On top of the screen, you can set cuttoff temperature of the MOSFET, and the motors.

If it’s too low, it’s normal it reduces the torque. However , I don’t think that it’s the reason, cause if you didn’t know about, there is no reason that you touched it and the default values are good.

What could help others to help you, is maybe a data analysis.(screenshot of the data). Under Data analysis (still on the left), there is the button Realtime data. Then, activate the button on the right side off your screen saying RT, and turn your motors for a while to have some datas you can show.

I hope I have been clear enough in my mess.

1 Like

The strange part about it is, that it worked just fine in the beginning and after a few rides it just broke… So some part of it must be broken right? I guessed it would be the Vesc, since its the only part that explains the strange behaviour of it but I dont want to buy a new one before Im not certain that something else isnt causing the problem. I can make a screenshot as soon as I get home again, right now Im abroad. The latest would be in 5 days.

Right…Also, which ESC did you chose? 4.2 or 6.6? If 4.2, it’s maybe a little light for this build…

1 Like

I used the 6.6 one.

1 Like

Welcome to the forum.


Sounds like a bettery issue. What battery do you have? and can you measure the voltage at the time it cant carry you anymore?

Yeah, I thought about battery too, if you used the ones recommended in your link, they might be light if you put high current in your settings.

As you describe it it can indeed sound like that your ESC slowly dicrease current to not kill batteries. What is the cuttoff you set for battery? (start and end). Also share us the current settings of your battery and motors.

And maybe check individually the cells of your batteries to see if they are well balanced. (on your smart charger).

This is my first run through the vesc tool, is everything fine there?

This is the second run through the vesc tool, as you can see there is something strange about the left motor… But sadly I dont know what this exactly tells me

Damn sorry I accidently reversed them… the second one I sent was the first run.

Those are all the other settings I thought could be useful to you

My batteries are those recommended in the build, see them here:

Okay, it’s easier to help with those infos!

First of all,your battery current specs are way too high. It seems that you let all the settings by default without changing anything.

It’s realy important to understand what values you are setting if you don’t want to mess with your build. (batteries here). You should watch a VESC tool tutorial.

For the batteries you have, I would recommend a Max current of 40A for battery, and -8 A for Max current regen. ( And it’s still maybe high). Your settings are actually 99A and -60A. (Too much).

Secondly (and that is maybe the reason why your board stops giving torque), your battery cutoff specs are low if you are running Lipo 12S. Cutoff start can be 43.20 V and cutoff end at 40.80 V.

Be carreful with battery specs (especially for current specs), or your Lipos won’t last long at all, and begin to be puffy and dangerous. There are many topics talking about that, take your time to understand basics, ask if you have doubts, it’s important.

Best regards!