I think I just blew my VESC?

So I finally decided to try FOC after running. I’ve read a bunch of topics about this lately due to the fact I wanted to see if there was a common reason for people blowing their DRV with FOC and alot came down to none-isolated motor cables and/or changing back and forth between bldc, or having wrong firmware version.

Isolated my cables. Followed torqueboards instruction video on youtube.

Did detection as in video and applied. Using the arrowkeys on keyboard without load was very disfunctional, didnt work all the time(which seem to be normal behavior in FOC). But I noticed after the detection it smelt slightly burnt and also it gave DRV8302 error the times when it did not work on the arrows.

I checked my parameters - everything seemed to be correct. Decided to try it on ground. It rolled with me on it. Tried it a couple times. One of the time it didnt wanna start. I moved it alittle and it started.

Its been running failfree on BLDC abit before this but never gone back and forth between FOC and BLDC. My versions are 2.18 firmware and vesc is a DIYELECTRICSKATEBOARDS v4.12 vesc. 10s4p - samsung 25R. Torqueboards 6374 motor.

Is my DRV toast? Does anyone have a clue why this would be the case?

Motormax: 60 Motormin: 30 Battmax: 60 BattMin: -12

Min volt: default Max volt: 57v cutoffstart: 33v CutoffEnd: 30v

I tried to find this issue on the forum but couldnt. And alot of threads were from early development on FOC so people may sit on more knowledge in this section now.

Best regards - pontus

can you confirm that it is giving a DRV fault by going in to the terminal and typing “faults”… sounds to me that it is another fault code

what is your absolute max current?

I would put battmax to 30A (ok maybe 40A)

130A is absolute max. Battery is at 60A (its rated for 80a).

And I was looking live analyzis in the “realtime data” and it gave me the DRV8302 on fault.

if you go back to BLDC does the fault happen again?

if the fault does not occur, may have badly written the FOC settings (not your fault, I’ve had the BLDC tool bug on me where hit write and it does not (don’t get the mc confirmation)). You could go through the FOC detection again

Could try, havent dared to since that used to be one of the most common ways to burn the DRV, swapping from FOC to BLDC. But at this point I dont feel like I have anything to lose.

Just reset to default and try. But smelling the DRV now I feel pretty certain its kaput.

c18 and 26 populated? I have 2 TB escs and these were not populated correctly which leads to errors on FOC

Not sure, according to their site it was “Upgraded C18 to 4.7µF”. And tested with FOC. Must’ve been my settings but I wish I knew how or which since I didnt change anything more then what I typed in this thread. Rest is default.

The card does smell burnt, and it started doing that already when I did the Parameter detect for FOC. Thought it was the motor at first. :confused:

Except for the smell there is nothing visually showing damage. From what I can see atleast

If you have the latest firmware the switching between FOC and BLDC is fine. The next version of my app will also have this feature. I would recommend to be at a standstill when you do the switch. It’s nothing more than a myth that this killer the drive. I just found out some stuff about FOC and how it can be optimized with the parameters. But I still have to learn and test a bit more before I can give clear advices.

Alright, I had 2.18, so that should be fine if Im not misstaken. Yeah your app was next in line for my project, that will have to wait abit now. Not sure wether to go for another VESC, or try and get this repaired.

Seems like FOC is still pretty “unknown” and still “Focs” up.(see what I did there).

Im currently lacking a hotair station so gotta find either one who can do it for me here in sweden, or borrow me a hotair station.

If you know any good suppliers in EU for vescs, I’d love to know. Shipping from US is just another 40dollar + wait time. Torture riding a board for 10kms then not be able to ride it again :stuck_out_tongue: especially in the weather we have now!


Yeah… I wouldn’t believe it. I ordered four 4.7uF caps for my two escs (a pair for each). The update between HW 4.11 -> HW 4.12 was a second cap added to c18 (namely c26) which was blank in both of my TB VESCs, I’ve heard of people having issues with TB VESCs in FOC mode but I haven’t heard of Ollin or Enertion have these issues and they do populate it

I got my VESC from this UK ebay seller. http://www.ebay.co.uk/itm/VESC-4-12-Motor-controller-open-source-BLDC-Speed-Controller-VESC-vedder-Pcb/182505114102.

Have run it in BLDC and also FOC with ackmaniacs firmware and its still going strong. Would recommend.

Which motor do you use with FOC? BTW, my firmware makes no difference when it comes to the reliability with FOC.

I use the torqueboards 6374 motor.

@yakerman Alright, Thanks alot! How was the shipping?

@PXSS Ah! Where are you from btw? I’d love to find a reliable source in EU for theese things, long shipping times is a bummer, aswell as sending it for service or replacement(If there is warranty that is).

USA. Sorry

I’ve been riding BLDC fpor almost 4 months with no issues at all, riding the board was a blast and tonsof fun.

Last week I decided to try FOC. FOC sensored was amazing, really, I mean REALLY SMOOTH, however it lacked of the power BLDC gave me, I had several cutouts at maximum duty cycle, right when I pushed the throttle to the limit, VESC cutted out, made stange unpredictable accelerations and brakings, I almost crashed 3 times.

I checked the faults and I gor the DRV8302 error, I knew I was screwed, however after turning the VESC off and on again, DRV error went away, I inmediately switched back to BLDC strong as always.

I’m not planing to risk a VESC right now, so I mihght try FOC again in the future when the software has more development and FOC runs with no issues.

1 Like

@Guacamoleface: Hello fellow Swede! Where are you located? If you need a hot air station, there could be maker spaces that has one in you vicinity.

Hey! Im located just outside malmö. I’ve been trying to think off places that might have with no luck.

Yeah with foc it felt like my power dropped on 100% throttle, most likely due to the drv. Where is your vesc from? Also does your vesc still function in bldc after all that?