Interesting VESC problems

Hello. My VESC seems to be experiencing technical difficulties. Please Help! :sweat:

here are the pics for my setup (sorry about the glare) skate%201 skate%202 skate%203 skate%204 and my settings skate%205 skate%206 ymMdueP3.png) this is what I get when I run the motor detection skate%208 skate%207 and the fault codeskate%209

Also, the VESC always blinks pink in sets of two blinks. I’m stumped to what could be causing this problem.

  1. Draw a diagram of your wiring and post that too. It’s hard to see what goes where with the wiring in your pictures.

As per Jacob’s comment. It would be easier to see what is going on with a clearer image of your wiring to rule that out as an issue.

I have never seen a VESC flash pink so all I can say is check for fault codes in the VESC Tool to see if there is an issue with the VESC.

From personal experience I had issues detecting motor’s and I had to lower D: 0.05 to D: 0.03 and it worked. That is my own personal experience and as I have never seen the VESC flash Pink it may be a completely different issue that you are encountering.

Good Luck!

Thanks! Here is the diagram ( i’m sorry i’m not much of an artist :sweat_smile: ) skate%2010

I hope you can see that well enough. If not, I can try to get a clearer picture

The batteries are all with HXT 4mm series connector wires ( the wires are 12awg)

are each of those lipo packs 2s?

you have cell count set to 6 in vesctool

whatever the pack S count is, multiple that by three, put that number in series count

I changed the cell count, but that did not help. I have been working on this for a while and am starting to think my VESC is seriously messed up :frowning:

Well, if you have a FAULT_CODE_UNDER_VOLTAGE, the sensible thing to do would be to take a voltmeter and check what voltage you have out of your XT90.

You would also have other info in the VESC terminal if you type “faults”.

nope. Nothing out of the terminal when I type “faults”, just the UNDER_VOLTAGE one. I will try the voltometer though

I just noticed in the ( Ackmaniac’s) ESC Tool that the battery cutoff are different for Li-Ion and LiPo. Not that it would help in your case if it’s an undervoltage, but you might want to set it right for the sake of keeping your batteries safe-ish.

Ok thanks. I will catch up tomorrow when I can head to my workshop to check voltage output.

@jojamcha you can check in real time to see your actual voltage reading from your pack. It needs to be above 20.40v (which you set it at) otherwise it won’t motor detect and will fail.

also turn your battery current wayyyyy down to anything below 40a

Yeah your cutoff may be too high, charge your batteries to full or close if you can and lower the cutoff