I've burnt out two TB VESCs... why?

Hello there!

Long story made short: I have been trying to build a board with dual sk3 5055 280kv motors. It worked for awhile, but the phase wires on one of them shorted. Dead DRV. So I ordered a better motor (KEDA 6364 190kv) because it’s cheaper than a new VESC. Yesterday, the second vesc died for no apparent reason. I tested it without load before the ride to make sure everything was working, got on, and it wouldn’t go. . Went home, plugged in the board, and it threw a DRV8302 error. Joy. I had the phase wires taped over this time, so it wasn’t a short. There was no visible damage to either of the chips. So I am wondering what caused the second one to burn out.

My current setup is: KEDA 6364 190kv motor (ran in BLDC mode) TB VESC Two 4s 5000mAh 20c LiPo batteries wired in series TB nano remote and reciever Anti-Spark loop key HK lipo voltage meter

Not sure if any of this matters, but the other specs are: TB 218mm trucks TB 63mm mount 90mm flywheel clones Arbor Axis 40 deck

I don’t have the money to upgrade to an Ollin vesc, so my next thing will be a FOCBOX unless I can figure out why the TB vescs keep dying. I would like to stick to vescs, because they are super nice for this purpose.

Pictures: Wiring Looking at BLDC Tool, it seems whatever happened reset the vesc settings too. I verified my settings by comparing with multiple other threads and videos, so I highly doubt that is the problem.

Input from @torqueboards would also be greatly appreciated.

I don’t have the equipment or knowledge to fix the DRV8302 chip, so I was planning on selling the vescs to contribute to the FOCBOX fund, unless I can get the TB VESCs replaced somehow. I read somewhere else that $30 was a fair price. Thoughts on that?

Thanks in advanced!

Ollin stopped selling HW4.12

  1. those pants you’re wearing in that wiring picture are awesome

  2. can we get screenshots of BLDC settings?


1.) Thank you sir. I take great pride in them :joy:

2.) The BLDC settings were reset somehow, so nothing useful would come out of that. When I went to take screenshots the settings were the same as the default settings, which definitely wasn’t the case. I compared them to other threads and videos to make sure they would work beforehand. I know they were fairly conservative values though.

So it will probably be even more expensive to get a vesc from him?

Are you sure you were clicking “Read” on every screen, then “Write” before you went to a different screen? Just changing the numbers does not change the numbers.

You can’t get them. They are unobtainium.

Yes I was. I double checked all the setting before I closed the program to ride too, just to make sure

1 Like

Ah. What about the VESC6 hardware? or does he have his own motor controller now?

@b264 @GrecoMan

It should be noted that this VESC was used less that 7 miles before it burned out

The only thing you can get from Ollin are the things they have listed for sale, which is nearly limited to belts and wheels.

He has them as far as I’m aware, but won’t sell them. He announced in late December he was going to be selling completes only, but those are not currently for sale, so I don’t know what is going on at Ollin.

he’s doing some cool stuff behind the scenes

@GrecoMan @b264

It looks like he has his own esc based on HW4.12. Although it is sold out.

Any ideas as to why this is happening to my VESCs?

did you hit wrote config after setting it up?

You can’t get them. They are unobtainium. He announced in December they won’t be for sale. So onto your TB hardware…

1 Like

Mention the step by step process on how you started/used it/programmed it.

As far as your motor wires… what soldering iron are you using?

BTW Those voltage meters you want to eventually disconnect from your battery pack when it’s not in use otherwise they’ll lower voltage on 1 or 2 cells and ruin your battery pack.

1 Like


Starting with the first setup (dual drive) -ordered, did tons of research to make sure I do everything right (knowing how fragile vescs tend to be) -wired everything up -verified the wiring with multiple videos and threads -turned on the board using an antispark loop key -connected to windows 10 pc with BLDC tool -put in conservative values for a dual drive -board worked perfectly until phase wires shorted and blew one vesc

Second setup (single drive) -same process, up until after the conservative values part -taped phase wires to make sure they didn’t short -Board worked perfectly again with new motor, until it stopped for no apparent reason

I never accelerated hard, and never went faster than 26 mph (crashed pretty hard at that speed and never had the guts to try it again). I rode dual drive for roughly 5 miles, and rode single for less that 2 miles.

Like i said in other replies, the exact values were lost due to the vesc resetting to default. I can’t give a screenshot for that reason, but I can tell you for certain that the values were conservative because of the fragility of the vescs.

Soldering iron

I disconnect the voltage meter after each ride.

Yes I did. I double checked all values before I exited out of BLDC tool, just to make sure

Got it. Any ideas as to why this is happening?

If you don’t click “read” on EVERY SCREEN then it’s not double-checking anything