**Lost of brakes when going full speed - Enertion Parts

Ok so went for an hour of riding to test out everything. Everything seemed fine until I was going at max speed I guess 23+ plus and I suddenly hit the brakes because i saw someone crossing the street and the board braked for 0.1 seconds and i felt it stopped braking. I tried to brake again and it didn’t do anything, after like 3 seconds i tried it again and it braked but this time i wen easy on the throttle while braking. It was a very scary experience. Curious to know what causes that. Any help will be appreciated as I need to fix that…let me know what do you guys think. My specs/screenshot of current set up are on the first post. Using exertion space cell 3, exertion standard VESC and 6372 motor spec r.

My specs:

Replace the max. Input voltage of 42V with 57V and test it again.

Are those values preset? If so, that’s not so good.

your max input voltage is probably too low, a voltage spike may cause the vesc to shut down…

Maximum Input Voltage 60V

is this mono or dual?

if its mono, i would change current limits:

Motor Max 60A Motor Min REGEN -20 (this really depends on your weight & preferences, maybe go down from -40 in increments of 5 & test it) Batt MAX 40A (slightly higher is ok, but eventually you’ll blow a fuse, go up in 1A increments & test it) Batt Min REGEN -12 (this is probably correct, it’s always best to try to keep Motor Min Regen & Batt Min REGEN as close as possible)

1 Like

Hey I replaced those earlier with this:

Was still giving me problems with it. It is a Mono.

Can you take a screenshot of your BLDC tab? If it doesn’t respond for 3 seconds it sounds like the VESC is rebooting for some reason.

Current configuration:

Can you check the advanced tab as well? There’s a setting (Max Current Ramp Step) in there that multiplies itself by 10 every time you write config on the motor config tab (software glitch). It should be .04 at default. Not sure if this affects your braking, but I’m sure it’s not great to leave at 10x/100x/1000x/etc the normal value. See here:

It could be that the battery regen braking setting you have is incompatible with the amount of current the battery could handle. Try reducing the regen current.

Here you go

yea looks like it multiplied by ten. set it to .004 and write config, this will change it back to the default of .04

So I input all the settings including the ones from @onloop and I am bench testing it. The board is at 100% and when i give full throttle and instantly try to brake it doesn’t do anything. Going slower and braking works just fine…any ideas?

what app config are you running?


any reason you’re on ppm/uart? most people run ppm, could you screenshot your ppm tab as well.

it came default like that. Haven’t changed it.

I guess you can try with ppm and see if that helps. Running out of ideas myself :stuck_out_tongue:

Also check what your remotes min and max pulsewidth is.

How do I check the remote?

connect VESC and check the display box in the above picture. Full throttle and you’ll get the max pulsewidth, min throttle and you’ll get the min pulsewidth. Put the values in the respective boxes and apply. Make sure to switch to ppm only!

You are running “multiple ESC over CAN” and “traction control” with a mono setup? That’s not a good idea.

it probably shut down due to high temps. Happened to me once, but I knew how to foot brake so I didn’t die :slight_smile: