Maker x go foc dv6 what wire connection go where

I need to know where specifically what wires from my board go where on the maker xgo foc dv6. I know where the motor wires go, but what port do i plug the sensor wires, power button, and the reciever for my remote ( have a Hoyt Puck and Voyager from BKB)? Also Do i need an Anti Spark? If my connectors dont fit the specific ports on the makerx im assuming that what the extra pig tail wires with connectors are for.

Ive looked and searched for weeks now and dont have the info i need. All the posts about the topic is about how to program or a specific connection. It seems like everyone either just knows what to do or got the right info that i must have skipped over. So i appologize if this topic has already been covered. And if so could you point me in the right direction?
Thank you

1 Like

Yeah. You are right. There is no manual for this and information on the internet is scattered and disjointed at best. I’m a complete novice when it came to this (still am), but with the help of @LeonCamero I was able to get my ESC upgraded to VESC and get riding again. You will not take the exact steps I did, but it should be pretty similar. You can check out the thread here.


Thank you i really appreaciate that. Ill check it out

1 Like

OMG!!! That info is excatly what ive been searching for!! That helps me out so much!! Thank you so much I really really appreaciate your help


“You’re very welcome” ~ @BourgeoisBastard


Well ive read through that entire thread link ypu gave me, which was VERY helpful., but i cant get VESCTOOL to connect to either my Tablet S7 or my Pixel Pro. I dont have a laptop or desktop computer. It just searches but always just shows nothing under “devices found”. Ive got an adapter so i can connect UsbC on my Android to the Usb A on the Maker DV6. Ive got a loopkey between the battery and DV6. The Dv6 blinks Blue and the reciever for the Hoyte puck blinks red while connected. But nothing else happens. What am i missing? I wish they at least came with a base setting so you could install it and run a basic factory tune.

If you do not have a computer to get it running, nor have a Bluetooth module for the esc, you might be stuck temporarily. You need software to get it started.

Im guessing you didn’t get the blutooth module.

No i didnt get the bluetooth module. Is that going to allow me to use my Android devices to tune the DV6? Cause i cant see myself going out and getting a computer just for this. I figured when it said itll work for Android, all id need is my Android device. And by software do you mean downloading the Vesctool program?

Yes. It doesn’t have a built in module.

Yes. You need to set it up.

Ive alrezdy downloaded Vesctool. Downloaded the one in the link off maker x website and the one where you have to “purchase” the free app (cant think of where i got that link from). Both cant detect anything. Anyways, i purchased the bluetooth modual so ill try it again when it gets here

1 Like

This keeps comming up when i try to connect.

Connect to pc and install bootloader first, then install new firmware. It’ll work after.

Maybe switch RX and TX pins for bluetooth module. Which bluetooth module did you get?

how vdo i do that? i have no clue what that means. im not very computer savy. i do have a laptop now so i have everything hooked up.

Download vesc tools by Benjamin vedder. You may need to make an account to get it. Then once you did that, connect your esc and just find firmware. Then install bootloader. Wait about 15 seconds and then install firmware update. Wait 15 seconds and then turn off the esc. Turn it back on , reconnect it to vesc tools, and then go to app settings and see if your esc is set to ppm and uart.

Disconnect and see if you can connect via bluetooth. It happened to mine. Got fixed after updating.

So i got it to work wih your help and reading everything i can. I do have a few questions related to the actual numbers ive got set. When i get home ill ask them. Thank you for yours and everyones help. Really appreciate it

1 Like

So i was using the BKB Voyager remote until i dropped it from pocket height (im 5’6"ish) and it broke. Just standing there trying to put it in my pocket and i missed. I cant believe thats all it took for this $110 remote to break. Anyways so now im trying to use the Hoyte puck. For some reason switching from uart to ppm makes my board from like crap. Going through the whole wizard set up and motor detection is fine. And when i use the throttle with the board not under any load ., Th e motors spin up fine. But when i get on the board snd hit the throttle it just makes a loud clunking noise and stutters like crazy. I might get a top speed of 5 mph if lucky. But i dont want to keep hammering on it cause im worries ill over heat them. Ive tried adjusting some settings bit nothing makes it better. Im At a loss and so frustrated with this. Oh and i cant connect to the bluetooth either. Ive get the Maker X modual too.
Please if someone knows what im missing please help me.

Did you set the dv6 as ppm/uart? You need to change the settings since you were originally on uart only. This will solve the issue and you should be able to do the ppm input set up via bluetooth.

If there are issues, you can just redo the firmware and reset the DV6 and you’ll return to its default settings.

Also make sure your hoyt remote is on the 3rd speed mode before setting up.

Edit: well that sucks. Dropping a remote and it breaks is just gay… for 110 bucks, it should had been sturdy.

Make sure you put a fuse on the charge port

I tried it at just PPM and also to PPM/UART. both do the same thing. And ive tried it with a pair of 6372’s, 6368’s, Ecomobil ET planetary’s, and TB DD’s. It does the same thing to all of them. Although i havent paired it in 3rd speed mode Or redo the firm so i do that? Also i cant figure out how to connect to Bluetooth.