Maytech MTES 120A 12S Sensor System with 6374-170KV Motors


We have ordered 3 complete Sensor Setups in China from Maytech for testing this on E-MTB. @squad : saw them on your tread, so first thanks for posting this mate.

Its in about 3 years riding E-MTB´s the first Sensored system i own. Really interrested how this will perform compared to unsensored Roxxys or MAX6 setups!

Ordered the USB-Links and the Progbox too:

Motors are as labeled : 63mm diameter, 74mm long, 817gramm wheight, 8mm Motorshaft, 25mm long 2mm Keyway, 19mm long … why not 3mm (-; 2 common bolting circles M4, 44mm and i guess 30mm 12AWG silicon Motorwires

Look from behind on Hallsensors:

Front wire inlet:

The Hallwires were only shrinked with the phase wires, looks not really good IMO Added some extra shrink in the outlet area:

One Hallwire were broken, fast fix but of course not nice by brandnew parts…

ESC´s : 58mm X 86mm 186gramm wheight similar footprint to the Roxxy, only the Elkos are relocated to get it slimmer. Aluminium Heatsink, 2 pieces, screwed

Dont like that the hallsensor connector sits on the side, better IMO to locate it on phase wire side…

Problems at the moment: Cant set the " Throttle Calibrations" in the instructions they talk about a set button you should use to determine the endpoints… but there is no set button (-: seems to work correct but feels strange… asked squad about and he confirm that he dont set it and it works … he is probably right that they just copied the instructions from another ESC

The Program Box connects to ESC but not more … i used the USB Linker instead and this works: You can set the common parameters… will post some pics later

So hope to do some real life tests shortly.

Hang Loose Jenso


Wow. They look awesome. Keen to hear the results of the testing.

I had two of these ESCs - one was faulty right out-of-the-box. Now support is silent since days.

R, J.

@nowind I hope they will work fine for You, with 63mm motors there is huge difference with sensored vs sensorless operation from my personal experience :slight_smile:

@kovjanos I guess it’s just infamous chinese quality control… sorry to hear that mate, too bad they didn’t sort this out right…

Maybe it’s salvageable, it seems like mosfet’s failed, it would require someone with smd soldering skills and hot air soldering station, I think it may work again with those faulty mosfets changed.

Yep, I hope somehow it will work - but would be more happy to have it replaced. With sensors connected the other ESC makes the motor clogging (very rare) on slow speed even if it has a smooth start (doesn’t have this issue with VESC). If it won’t work out the right way I’ll wait for VESC 6 before investing into another pair of Maytech ESCs as there is no way back to non-sensored configs :slight_smile:

R, J.

Curious to hear your results, because I am planning an MTB build. How much did u pay for each unit? If u don’t mind me asking.

You may need to change sensor wires arround, probably Your hall sensor order is not corresponding to phase wires.

Check this out

1 Like

Wow awesome. I’m planning on picking up some of these, good to see someone else is using them!

I tried all the possible variations to find the one which worked. …but even the best one is clogging sometimes (very rare). Actually I kept the sensor fixed and played with the phase wires - my understanding that this is OK.

R, J.

If so, then maybe one of Your hall sensors has failed? It’s simple to check with voltmeter, it should give 0 then 5V and then again 0 etc. as You slowly turn the motor by hand.

Sorry Jenso for highjacking Your thread.

No its all good, it was thought to discuss this sensor system, your input is really apreciated :kissing_heart: I´m in rush right now, will give some updates later.

Sorry to hear, you dont get any reply from the seller? Since how long? We have emailed him because the wrong documentation and get instantly an reply.

Maytech sends us new instruction for the ESC, and told us that the throttle calibration is not needet with this “special skateboard ESC”… So its like @squad said. Dont know if its possible to upload PDF, if so i could share the actuall instructions !

I got both ESC´s and Motors now soldered and programmed. Both work in sensored Modus, just have to change one phase wire on one ESC. Programming via USB LInk is easy, but the Progbox still not working.

Machined a Rc plate for mounting:

Mount one ESC upside down to have the hallconnector on the outside:

I used for the first time the “SUGRU” to secure the Hall wires on connector. Thanks to @whitepony for mention this stuff on one of his posts. Lots of possibilities … like it

Now actually waiting for the 2mm Keys to complete the buildup and go for real life test.


4 days - but this is constant. Got now 2 replies but always had to wait that much…

R, J.

Are you sure that these ESCs have the same environment sealing like your other car ESCs? I’m not sure…

R, J.

They are labeled as “splashwaterproof” but i will not test this (-; Its not a board i will run in the rain. But dust and debris will not be a problem, so i see no need for a extra housing.

They are far away from being splash-proof. The case doesn’t seal the cables, cap bank is almost full open plus the sensor connector and led hole is wide open. The works is around the phase wires, those SMDs are placed too close to the openings. Actually those are placed too close to the cable soldering points and the positions of the fets’ metal heat–pipe-leafs are also quite risky.

I got some replies and updates but still not a big step forward.

R, J.

Yes you are right. As i said i will not ride the setup in the rain.

Today i mounted the Gears and do a Benchtest on 12S. Both ESC are working but with at least half the power they should delivers. I´m sure that this has to do with throttle calibration, maytech told us that its not needet by this ESC (and also not possible) but its like only half throttle.

Same effect by my friend !!!

What let me think thats has to do with Throttle calibration : If i give full throttle i can increase RPM by turning the “throttle poti” this is IMO a proof for missing throotle calibration. I dont get full RPM but more.

My friend tested two different Remotes, one is the original Maytech Throttle Remote. I used the common 2.4ghz Miniremote, will test with my DX3R Pro Remote also this evening.

We contacted Maytech also, hope on fast reply.


Maybe you can try the following trick:

Full throttle --> turn on the esc wait till it beeps and then go neutral wait till it beeps and go full brake

after it it will be configured. Well it is just a guess :smiley: My YEP helicopter esc is working like that :wink:

1 Like

I’m wondering if you have the Maytech MTES120A Users Manual.pdf which is really for the 120A version as my PDF is sh*t. Looks like a mix of EZFUN and 120A.

I’m also wondering if you get the programmer working as the PC software they sent over is a bit “unfinished” - you can set the battery type, the cell level cutoff value but you can’t set the number of cells in series :slight_smile:

R, J.

I got a doc from them because I had the same issue. The doc doesn’t look like the right one but has the following for calibration:

Throttle Range Calibration: Note: For the first time using transmitter or changing the transmitter you must set Throttle Range Calibration.

◆ Switch off the ESC, connect it with battery pack, then turn on transmitter, set the direction of the throttle channel to REV; set the throttle trim to “0”; set the EPA/ATV value of the throttle channel to 100%, and disable the ABS function of your transmitter.

◆ Hold the “Set” button and switch on the ESC, wait for about 2 second until the Green LED begins to flash and the motor emits continuous ‘‘Beep-beep-’’ sound. then release the ''Set" button and pull the throttle trigger to the neutral point at the same time, then you will hear a continuous “Beep” sound and see the Red LED continuous blink, then click on the “Set” button, hear “Beep” the sound of the motor.

◆ Push the throttle trigger to end position of forward, press “Set” button for one time, you will hear motor ''Beep-beep-".

◆ Now push the throttle trigger to the end position of backward, press “Set” button for one time, you hear motor “Beep-beep-beep”, both of the Red LED and Green LED turned off simultaneity, the Throttle Range Calibration is confirmed , the motor can be started after 2 seconds for battery cells detecting program.

R, J.