Miami Boards Vesc - Troubleshooting

I have a VESC 4.12 from Miami Electric Boards however I’m having some issues. I tried updating the firmware according to the VESC Tool and it loaded but crashed at the end and now when I power up it gives me a solid yellow led and won’t connect to the tool via usb. I thought maybe I needed to flash the bootloader but the pin layout is different than the other Vesc’s so I’m not sure which conncetions I need to make. If someone can tell me which pins to use and the wiring configuration it’d be appreciated.

Thank you in advance,

Joe

You can try flashing the bootloader using vesc tool.

1 Like

Is there a way I can do that if Vesc tool won’t connect via usb?

A stm can do it I think

If it won’t connect via usb you can try another bldc tool. If that won’t work your only option is stlink. Check the thread above. You can also do it with a raspberry pi if you have one.

Thank you for the info… Just one more question. Which set of pins do I use on this Vesc? The layout is different and without indication.

-Joe

Unfortunately I’m not much help with that. Use the search function. There’s lots of info about this subject already here. I’ve had similar problems and I’ve seen posts detailing the pinout. It’s just a matter of finding them.

Thank you for the help. What is the pin configuration for the st link? I tried, starting from the left side, 3.3v, SWCLK, GND, SWDIO, RST however even with this configuration I’m still having difficulty connecting to the STLink Utility…

I’m at a loss with this and would greatly appreciate some help.

Thank you, Joe

Here’s a pic of what’s written under the connector

I tried that configuration without luck…

Hmm, that’s an identical VESC, so those should match up. Unfortunately I do not have schematics for that one, so that’s the best I can do right now. When you plug it in are you getting any lights to come on?