Mini FSESC4.20 dual problem

So, I bought two mini FSESC4.20 and I connected them via CAN. I set up everything: Master > ID-0, send over can: no, multiple escs over can: yes PPM with UART, and can cable plugged in Slave > ID-1, send over can: yes, multiple escs over can: no no app

Now, only the master motor spins. I did everything again. Ackmaniac 3.102 firmware. Motor detection, etc. Again the same. Only one motor spins. I even soldered the can cable direkt to the pins. Still no. Does anyone have any ideas? I used to run dual VESC 4.12 with no problem before that. @BensonYong

1 Like

Try follow this guide :

Did you plug in the canbus wire while power was on?

No, everything was connected beforehand

That´s exactly what I did. But still only one motor spinning

do they work individually?

Yes, they do

well, i run mine over split ppm, so no real expierence in can bus mode

1 Like

Try switching master to slave and vice versa

good idea. I´ll try that tomorrow!

Don’t you need to set „multiple vesc over can“ in master and slave to yes? :thinking:

Nope only master

I thought I have set it in both :thinking: Nu ok thx for clearing this up

1 Like

tried the switching. Did not work either

Probably a dull vesc. You can split ppm if you don’t need canbus. But probably better to send ut back

Hi man.Sorry, I didn’t reply to you in time. Has your problem been solved?

What I did was turn the switch to off first…

Then I ran the connection wizard for both escs, one for master, one for slave. The slave one has to be set to a different ID the. The master. Somehow the wizard worked better than when I tried doing this myself.

After this is done, turn switch back on (power down first). Then give it another go.

Incidentally I usually do all the motor detection separately too…

Not yet, seems like the CAN doesn´t work. Is there any way I can check, if the connection is working?

How can I run configure the ESC when the power is off? The problem is that both esc work on their own, but not in dual.

No I mean when u swap the USB cable turn off the power…

Setup using the wizard for both master and slave.

Incidentally, you are testing the motor movement with a remote?