Mini FSESC4.20 dual problem

Have you tried multiple escs over can: YES on the master and slave?

We have received the feedback video from you and we will resolve your issue as soon as possible.

1 Like

Yeah, did that. @DeathByBacon: Tried that as well. DidnĀ“t work

Does anyone know how I can check, if the CAN connection is working?

I wonder if u can test for connectivity using a multimeter on the CANBUS pins across the two escsā€¦ Just to make sure that they are indeed internally connected via the switchā€¦

EDIT: I apologies, I re-read your post, you bought TWO mini VESCsā€¦ I thought you had the DUAL VESCsā€¦ apologiesā€¦ In this case make sure you connect the CANBUS wire in the correct order.

I just connected the two middle pins, but it doesnĀ“t work

Did u connect the right pins to each other?


Running out of ideasā€¦ Are the two ESCs grounded to each other? (e.g. share the same battery).

Also, are you using your remote to check if they spin in unison or the VESCtool desktop app?

Tried everything. Running out of ideas as well. Gemma from flipsky now told me I should send them back

Make sure thats not a cold solder on the CAN connectorā€¦looks abit suspicousā€¦

Had a normal can bus cable on it before which worked fine on another setting. Solder is solid

What do u mean the cable worked fine before on another setting?

I had two tb vescs for two years connected via can before that. Then, one vesc blew up and the other one didnā€™t work properly, so I switch to flipsky vesc

So, I couldnĀ“t get the two ESCs to work in dual mode, but they offerend me to send it back and refund my money for store credit and they pay for the shipping. Will order the 6.6 dual next and hope that I will work :slight_smile:

1 Like

I used to have that issue, I solved it by changing my cables be cause the CAN connector wires was a dud for some reason.

He soldered the pins directly and still couldnā€™t get it to workā€¦

1 Like