Motor cogging on startup with load

Hello everyone!

I’ve seen quite a few people having the same issue as me, but I couldn’t find a solution that worked for me so here I am.

When accerlerating without any load there is no problems, but with load the motor dosen’t accelerate that well. The motor starts cogging and the VESC makes some sounds. Here is a video I made that shows the issue.

And here is my VESC settings.

Realtime stats when accelerating


Any input will be appreciated :slight_smile:

What KV, battery and gearing are you on?

My motor is the 6355 190KV from TB. Vesc is from TB. Battery is 10S6P 30Q. Gearing is 36 on wheel pulley and 16 on motor pulley. So gearing is 2.25 if im right?

I was thinking maybe the gearing was steep but that sounds ok to me… it’s acting like sensorless but your settings look ok.

maybe someone else can offer sage words.

1 Like




You should just give it more throttle and it should give you more power.


Are you sure that you performed that sensor detection well?

Mind sharing the hall sensor values (I see the same value on your video)


Maybe increase the amp settings. Always works for me. Looks like 20 max motor amps on the graph.

1 Like

You’re right. It looks like the max amps is 20 on the graph. I’ve set the max amps in general settings to 70 and 40 though?


Think I do perform the sensor detection correct. Here is a video of it.


these are my values, yours are much lower.

Can anyone confirm that the values from the video seem ok?


wow. there is a big difference.

Are you sure you are actually writing the config to the vesc? Seems like its on the default config.

1 Like

There will always be some cogging if you’re using an unsensored motor. As someone mentioned above applying bit more throttle usually does the trick. When standstil the vesc has no reference of motor position so it attempts to make it spin very slightly… Ones it traveled abit youll take off. As you mentioned theres no problem starting with a little speed. Since the motor is already spinning the vesc gets feedback right away. Youll notice starting from standstil with some incline is even worse. If this is brothering you i sudgest using a sensored motor.

1 Like

Just tried running my motor in FOC mode. Off topic: WOW IT’S QUIET!

Still same issue.


@bevilacqua Are you running FOC? Tried to run the detection under FOC mode and get some results close to yours. I normally run BLDC


@Fiori Im pretty sure I am. It’s says in the buttom right “MC CONFIGURATION UPLOADED”

@linsus The motor is sensored. That’s the issue. If it was unsensored I know it would be completely normal, but since it isn’t, I don’t want that issue to be happening.


yes FOC, maybe thats why.

Sensored FOC should be much smoother on startup than Sensored BLDC.

What vesc HW/Vendor are you running? 10? or 12S?

1 Like

HW= 4.12 FW= 3.38 Vendor: DIYELECTRICSKATEBOARD Battery: 10S

try to run FOC, apparently TB-Vescs can run FOC @ 10S. Other than that it appears that everything was fine after all. Just BLDC on a single setup

1 Like

@legend27 I’m still not sure what you’re issue is? Is it just cogging at start-up?