Motor detection fails with VESC tool

Hi!

I have a setup with the following parts:

I think I read all the topics there are on the forum but I still didn’t manage to make the motor detection work in BLDC mode.

Here are the settings from the setup wizard: image image image

Here are the settings I tried the tool to work with: image

I played with all kinds of values for I, omega and D parameters without any luck. The ones that I think are closest to working are included in the last screenshot. Each time I start detection it ends up with Bad detection result received.

Here is a video with motor behaviour:

In the console I checked for faults with commands fault and faults and received FAULT_CODE_NONE and No faults registered since startup.

Some other things I checked:

  • The continuity on all the wires is OK
  • I swapped phase wires around (the direction of the spinning changed but nothing more)

I also tried FOC mode once, in that mode I was able to fetch all run the detection correctly, however the driving of the motor (either through RPM set or arrow keys) didn’t work very well.

Any ideas on what else can I check would be highly appreciated!

You’re being throttled by the battery cutoffs.

Make these values under 20V

Cutoff start 12V Cutoff stop 10V

For lab testing with psu

image

Thanks for a tip! Should I do it even if the supplied Voltage is 20V? I changed the cutoff values to the ones you suggested and the behaviour is the same (at 20V and at 12V from my power supply). Do you have any ideas what I can test?

Leave the power supply at 20V

Cut off start: if input voltage is lower than this value, your current will be limited.

Cut off end: if input voltage is lower than this value, power to the motors will be completly throttled.

Other thing you can try is increase your detection current and increase the detection duty cycle (D)

I tried modifying the detection current and duty cycle without any success. Do you have any ideas what else could I try?

Here is also how the motor behaves during FOC flux linkage measurement, which in this case is successful (however the values seem a bit sketchy to me, especially the KI parameter):

And the results: image

try these detection parameters for foc detection

I: 2 to 4A

D: 0.10 to 0.15

w: 700 to 1200 ERPM

maybe @Deodand can have some input here, i’ve never played around with fancy maxon motors. I do find your flux linkage very low… but then again, lack of experience with this type of motor

The flux linkage measurement is definitely too low. Resistance and inducatance measurements look ok. Since it is a maxon motor the datasheet will give you rpm/V (which is kv) and you can use this to calculate flux linkage (lambda) and input it manually:

lambda = 60 / (sqrt(3) * pi * kv * pole_num)

If this doesn’t work you may need to add choke inductors to the windings if the winding inductance is too small. You wouldn’t need these expensive ones, just an example. Some around 5-10 uH would be more than plenty.

An update: All the things mentioned above were failing on me (the only thing I didn’t try were the choke inductors).

I just got my hands on another one of those motors and it works well with VESC out of the box.

Thanks for all the help!

1 Like

I would also change the battery max Amps as well

Thanks! Would you change it even if working from 5A power supply? With the battery I would probably set it to whatever is the discharge rate * capacity. Would that be correct?

You would set it to the discharge rate x how ever many parallels you have

Hello, I have also the same problem. When I try to make a motor detection I have a bad result received .

what firmware are you running? what vesc? what type of motor? and FOC or BLDC?

Hello Here what I have

2 x Torque 6355 Motors 2 x VESC : Turnigy SK8-ESC V4.12 For Electric Skateboard Conversion w/BEC

12S battery (2 x 65 5000mah 40C)

Fo now I just connected a single battery to vesc to configure it.

So I connected it to the battery and the motor. Then connected it to the PC. Then I launch VESC-Tool. Here they tell me that my firmware is old and that I have to update it cause I will stay in limited connection.

So I update it and now I’m in : FW 3.38 and 4.8 HW.

I start to configure Motor current Max, Regen and so on based on what I have read and from diyelectricskateboard customer service advises.

Then When I tried to make a Detect BLDC Parameters, I get a status failed …

I’ve tried to change cutoff start and end to the barely minimum but nothing …

I also tried to re-update VESC, still nothing …

You flashed the wrong firmware your vesc is a version 4.12 meaning it would be a hw412 in the vesc tool. You flashed it with hw 4.8 that is the cause of your issues

Don’t remember they ask me what firmware I wanted … So I need to downgraded it ? Is there a bin file for it ?

no you updated the firmware and but when you flashed the firmware it was for the wrong hardware so you need to try and flash the firmware file for correct hardware which is 412. if you download @Ackmaniac esc tool it has a very easy step through guide to do your motor detection and remote set up after you do the firmware update

So I try to reflash it now im in FW 3.01 HW 4.10

Detection work (Thanks=), it spin but not with the remote controller …

I’m going to use y-splitter instead of CANBus. Do I have to configure each VESC independently then the receiver each time ? (I know i have to cut a wire to only have 5 V for the reveiver)

Best Regards

Yes you will have to do each one independently honestly canbus or a lot easier because one is master one is slave is for master would be 0 and the salve would be 1