Motor detection fault

Hi all I’m quite new to electric skateboards and have a basic understanding mostly due to others hard work. I have an issue with my board which I can’t solve Today I took the board out running slow as my daughter was following on bike, as I was slowly braking it just died !! I have fully charged batteries 2 x 6s 22.2v 3300mah lipos they read at the moment 49v Flipsky fsesc v4.12 lights on receiving power all connecting to laptop Torque boards 6355 190kv motor, tested resistance 0ohms So when I pull trigger green light on esc I cannot find any visible issues anywhere I have checked and double checked connections all are good But nothing happens to motor

I redone the set up wizard just in case and it just says motor detection fault Real-time data shows nothing

A little history for those still reading :joy:

Recently I added a flipsky smart anti spark switch this seemed to work when installed but little did I know that power was still running to board so completely drain 2 6s 22.2v 5200 mah batteries killing them… So I removed the not so smart switch and replaced batteries and went back to an xt90 anti spark loop key I used the board twice and then just died.

So any ideas or help on testing if power is being sent out of esc would be helpful

If you have a multimeter you can check the resistance of all combinations of phase wires (a to b, a to c and c to a). The resistance should be very low but the same in all combinations. Also check if no any of the phase wires have a short to the motor mount or ground as well.

Make that before you do another motor detection. If you have a short in your phase wires you can broke your vesc by doing a motor detection.

When you did the motor detection, the motor was as min turning or rattling, or didn’t do anything at all?

Just to double check, there also no red lights in the vesc after you did the motor detection, right?

1 Like

Hi Andy thanks for replying.

I’ve checked with multi meter the 3 phase wires on the motor and I get 0 in all combinations I’ve now checked the 3 phase wires from the Vesc and I get around 81.0 on all combinations although slight differences. There is no red light there is a constant blue and green And when running detection I get brighter green which comes on assuming that’s it sending power to motor Which is same as when I pull trigger on controller.

I did just check resistance on the terminals ( solder points )on the Vesc and I got 0 resistance ! Does this mean I could have a break in connection on wire between solder point on board and connector?

If it would be a break your multimeter would show open end and not 0 ohm.

1 Like

Scrap that last just checked reactance on each and get 0 so wire ok grrrr :thinking:

And you say that after you get the message „bad motor detection“ there are no any faults written in the terminal right?

1 Like


Yes that’s what I get

Did you do motor detection with belt and wheels on or without?

1 Like

I tried both, the annoying thing is that is was working fine, did a couple of miles I’ve 2 days just short run to shops, and it just stopped working so settings were ok for it to run But it’s not even attempting to spin up motor not a flinch

Did you also try bldc as well as foc. Maybe one of the both get the motor detection running.

1 Like

I tried both Foc detected motor but didn’t run motor I’ll try again now

image It said motor would make noise and then motor would spin but motor did nothing But I got green so assuming it detected motor?

If it’s green it should be good. Can’t you apply that settings and continue with the wizard?

1 Like


Sorry missed one step and this is what I got

Disconnect the sensors and try to set your motor up sensorless.

1 Like

Unfortunately I’ve tried that already as well

You also can’t spin up the motor with the arrow taps on your pc?

1 Like

Sorry couldn’t answer as wrote maximum replies as new use lol

No arrow tabs do nothing either. Unfortunately I don’t have spares or I could swap out either motor or fsesc and eliminate that way. I really don’t want to buy the wrong bit. Any other ideas to find which is at fault? Is there a way to spin up the motor without an esc? I noticed slick revolutions are close to me might pop in there in the week and see how helpful they are.