Starting Tips | Ask Questions | Introductions | Categories

Motor issues after detection

So i did the motor detection and followed the directions according to Marcin Sleziak’s video instruction. However, after selecting current no reverse with brake and writing configuration the motor is not rotating. I have a FS-GT2 and when i press the throttle i do see a green light on the VESC. I have already uploaded the firmware for my VESC 4.10 already. help?

@arpitdave After you write the config you need to reboot VESC. You also need to pair you gt2b with the receiver. Have you tried both of these steps?

Oh wait - you’re seeing a green light so you are paired and presumably rebooted. In that case, I’d guess that you haven’t selected a motor control option. Select BLDC from the motor tab, write config, reboot.

hmm i did that but still no motor response. When i do the start detection on that same page I get a bad detection result received error. Any other ideas?

@arpitdave “The bad detection result received” error might be a very important clue. Does your motor spin up during detection? Can you control it through BLDC Tool using the keyboard? Perhaps there’s a wiring issue between your motor and VESC.Double-check the wiring to make sure everything is right, posting a pic here would help all of us to review your setup and give you advice :slight_smile: Screenshots of your BLDC Tool Configurations would be helpful a well.

The motor does not spin up during detection. Is it supposed to? I am going to re-solder the motor connections to the VESC and attach a picture soon.

@arpitdave Yes, it is supposed to spin up during motor detection. If it doesn’t, something is wrong. There are several tutorials to check out. @onloop made this one about motor detection I’m suspecting that your wiring needs some correction. GL!