Motor stuttering when accelerating too fast

Hey all,

I got my Honey Driver build finished recently but am having an issue with the motor stuttering when I go full throttle from standstill or if I otherwise accelerate too quickly. Any help on this would be appreciated! Details below…




  • Using PPM with min/max pulsewidth custom set to for the remote.
  • Multiple ESCs over CAN set for both VESCs
  • Dual diag configuration
  • Slave (front) VESC has “send status over can” enabled
  • I’m 79kg
  • This doesn’t happen when accelerating slowly then speeding up, so I think it has something to do with the sensors.
  • Tried upping the sensorless eRPM from 2000 to 6000.
  • Tried lowering the sensorless eRPM from 2000 to 1500 (as shown in pic)
1 Like

That’s not a good idea, it should be enabled on the master only and not on the slave.

Also, it might be better to set the “max. current ramp step” to the default of 0.0400.


Sorry that picture was before I wrote config. It changed to .04 after I wrote.

Also, if I dont turn on multiple ESCs on the slave, wouldn’t it not have traction control? That’s the main reason I turned it on.

@Jinra Try lowering your motor and battery amps. You might be tickling the over current cuttoff on your BMS.

I think the BMS should be able to handle burst current. I’m not confident this is the issue since the board never cuts out, just stutters on dead stop hard acceleration. Note in the video I release throttle just to show the issue; if I held the throttle it would eventually get up to speed and travel smoothly.

Is the problem only occurring when you stuff the throttle? Does it behave when you gradually apply the throttle?

FYI, I can trip the over-current on a bms with 100 amp capability with the setting you currently have. I am pretty sure the bms you have is not capable of 100 amps.

It happens when I full throttle, or otherwise accelerate too fast from stand still. If I ramp up more gradually, it works perfectly.

Also, try lowering your low voltage start to 33v. You could be triggering the back off strategy when you apply heavy throttling.

I can try that as well. I’ve been testing this from full charge.

This is one of the main reasons I use 60+ cells in my builds. You really only want to pull a maximum of 10 amps from those cells regardless of their 20 amp rating. Try lowering your settings to 20 amp battery and 30 amp motor max. Personally I think that is still to high for a 40 cell pack but it should work with fresh cells.

Ideally we would only pull a maximum of 5 amps per cell but that requires a very large pack.

Here’s what vedder said about the option. I noticed he mentioned that send status should be on slave, but made no mention on how"multiple escs over can"should be configured. I was assuming it’s okay to have it on all VESCs.

Multiple ESCs over CAN can be enabled to connect several VESCs over CAN bus. All VESCs must have different Controller ID and the slave VESCs must have Send status over CAN enabled

Thanks for the recommendation @chaka. I’ll take note of those settings. However, I do go up pretty steep hills with no problems. I have a hunch that this is a sensor issue, but haven’t tried running the setup in sensorless yet.

The slave always takes the commands from the master and traction control will work. So, if it’s enabled at the master that’s ok. But it should definitely not be enabled on the slave.

Gotcha, I’ll try it out and report back :slight_smile:

Update! @elkick @chaka I explained in the video, but the problem seems to be less severe and less likely to throw me off now. It still happens if I crank to full/near full throttle too fast from a dead stop.

Changed settings are as follows:

  • min erpm now at 200 from 250
  • sensorless erpm now at 2000 from 1500
  • motor max now at 40 from 60
  • battery max now at 30 from 40

Have you tried running through calibration again? Integrator limit and bemf coupling measurements seem a little off.

i calibrated on 6s but haven’t done it on 10s since i didn’t want to redo my loctite, but I’ll give it a shot. What’s yours?

I run calibration with the belt on, just make sure the wheel can spin free. My board with 200kv is set , Integrator Limit 130, BEMF Coupling 860. I usually run motor calibration a number of times and take the average measurement.

Honestly I prefer sensorless operation for simplicity. I still would like to find out what is going on with you settings.

1 Like

Oh really? I always heard you should run calibration with a free spinning motor. When i did calibration with pulleys, my results were higher i just never set it.

Until you get your settings sorted out I would refrain from applying full throttle from a dead stop. Even after you get it sorted out I would refrain from doing this as it is bad practice on anything with a motor.