Motor stuttering when I try to accelerate - where's my problem?

I’ve been riding my esk8 for the last 8 months without any issues at all, then all of a sudden it stopped working on me today. Whenever I try to accelerate now, the motor violently stutters (so badly that it’s far from being rideable), though the brake still works. I took my board apart and hooked up my VESC to my BLDC tool and I can’t seem to find the issue. I tried accelerating and no fault code came up at all. However when I try to do a motor detection, after some angry violent stuttering from my motor, it keeps saying bad detection result received and “detection failed”.

Board specs: Battery: Space Cell Pro 4 VESC: Enertion Motor: Enertion 190kv

Below are my VESC settings. In my realtime data, is it normal that the “current in” stays so low when I accelerate?

Any help is hugely appreciated! I hope I didn’t short my motor…

1 Like

Sounds like a phase wire short to me. I’d check your bullet connectors at the motor and the VESC. Also check where the wires enter the can of the motor. You may have to remove heat shrink to check it well, just replace it when you are done and don’t short them.


It could also be a disconnection of one of your phase wires. Example: if you unplug 1 phase wire on a working board and try to accelerate, the motor will just stutter. you could have a bad solder joint, or a broken wire.


I don’t think you shorted your motor because a motor short will usually kill the DRV chip on the vesc and you would have a DRV fault show up in realtime data.

@Namasaki @mmaner Thanks for your input guys, but I can’t find any short in the phase wires connecting to the VESC or to the motor itself… nowhere can I find uncovered wires touching each other. Could it be an issue within the wires themselves?

@Namasaki if one phase wire is disconnected from a working board, is that board still able to brake? The brake on my motor still works fine.

Turn on active sampling then try accelerating just a bit on the throttle. See if the bottom left Fault Code area gets populated with an error.

Also change your max input voltage back to default (57v)

@Nicolai could you post some pics of your setup, highlighting the wires, connectors, and points where things are soldered? Sometimes a fresh pair of eyes looking at it can help!

Hey Jinra, yeah I’ve tried that already (see the last screenshot I put up) but no fault code appears when I accelerate. Is it weird that the “current in” stays so low when I accelerate though?

Yeah, let me try to upload one!

No load current should be low. However, there should be a large spike when starting up in line with the other peaks of the red and green lines. Perhaps something on the VESC blew that prevents it from drawing the needed current. Hi-res pics of the VESC would be helpful.

PS. If it turns out you need another VESC I have an extra and I’m right in your neighborhood :slight_smile:

Here see if that video helps at all…

And @Jinra let me upload some right now. Thanks for all the help guys!

1 Like

Hm it might be a motor issue as well, but I don’t see anything obvious from the vid/pics. One thing I did notice is that your motor is not on the mount securely. You can see it jumping around when you try to throttle, it must have loosened up, make sure you apply threadlocker.

That stuttering looks like a poor connection on one of your phase wires. I’ve seen it before on one of my builds. It turned out that one of the bullet connectors had a cold solder joint.

And when you say you “lost a bullet connector”. How did that happen? Did it just fall off? If so, then all your bullet connectors would be suspect for poor solder connections.

I would suggest that you remove the shrink wrap and have a close look at all your motor to Vesc bullet connections. Twist the wire in the connector and see if you can break it loose. Check continuity from the tip of the bullet connector to the wire before the solder joint. Check for solder flux inside the female bullet connector or on the male bullet connector. Also when you put then together, they should be very tight. Last of all, open the motor and looks for loose or broken phase wire inside the motor. That last guy that was having this problem found a loose phase wire inside his motor.


I was just about to say what @Namasaki said! Look at the broken bullet connector, that is almost certainly a connection issue w a phase lead. How did you solder the lost bullet connector?

If you soldered directly to the motor wire, did you remove the coating on the strands beforehand?

Btw great video I wish everyone w a question on the forum made a video like that, makes it so easy to help!


I really appreciate the help guys! I’m away from my build right now but when I get back I’ll try everything you guys have suggested and I’ll let you know if I still can’t seem to figure it out. Thank you!!

1 Like

Hey guys, so I’m still struggling to figure out my problem. Here are some modifications I’ve made to my setup. I’m pretty sure this method of connecting the phase wires together would mean a foolproof connection, but I could be totally wrong about this. Please let me know if I’m going about this the wrong way completely.

@Namasaki I’ve gotten rid of my bullet connectors on both the motor and the VESC sides, and just wrapped the phase wires together without any solder or flux to get in the way… This should prevent any “cold solder joints” right? @Jinra thanks for your tips, I’ve reset my max input voltage to 57v, I’d love to hear what you have to say about my realtime data when you have the time. @treenutter I lost the bullet connector a while ago, I had been running my board without a female bullet connector joint with the loose phase wire (that would be holding the female end of the bullet connector) just soldered into the male connector, then wrapped all the ends in electrical tape to prevent shorting in the phase wires.

I seriously appreciate all the help you guys have been giving me. Do you have any further advice? Any idea what my problem might be? @carl.1 @onloop anything on your end?

Finally: keep in mind the setup I’d been riding had been working flawlessly for about eight months, until it suddenly wasn’t. No crashes, no serious stress on the motor. I was just riding along then all of a sudden when I tried to accelerate I almost got bucked off the board because the motor started stuttering on me and now I’ve had this issue ever since. Also, I can still brake totally fine. It’s just accelerating that’s the issue.

Have you redone any motor detection ? Also, please use some connector :wink:

Just ran the motor detection, detection failed. You mean solder the wrapped phase wires together?