Starting Tips | Ask Questions | Introductions | Categories

My kid stuck a metal allen wrench in the charging port... Whats broken now?

I have the DIYEboard all terrain, which despite what everyone else thinks was working great for me. I was switching the AT wheels to the street wheels with my kiddos (I try to let them “help”) when I reach down to grab a street wheel a hear a snap and see a spark. My kid has stuck the metal allen wrench from my “T” tool right into the charging port of the 10s5p battery. The board won’t start now… what’s more than likely busted at this point? (Whole battery, some cells, bms, esc?) Any advise would be great.

Open her up. Pictures pictures pictures

1 Like

Could be any of the above. Did ya fuse the power switch or charge port? Tjat would be my first check

Most likely you’ll just need a new charging port.

I really didn’t want to open it up as I would have to loose my grip tap but owell. Strangely unplugging the battery and looking at it nothing physically looked wrong. I plugged it back in and tada! the board now works (on the bench). Plugged it back into the charger and it’s charging too. So it looks like all that was wasted was ~$10 of grip tape. I will close the topic once I get a chance to test everything out better and confirm working. Not what i wanted to be doing tonight but damn I feel lucky.

We are assuming you are referring to the board right?

5 Likes

Not the kid

8 Likes

lol it was tough not to loose it a bit in the moment.

4 Likes

Same thing happened to me. Messed up checking voltage with my multimeter. Freaked out. Tried to charge it and started working again.

2 Likes

You should have tried to just cut the grip where the screws are as not to ruin the entire length of grip.

Glad it’s working tho I’ve done this a few times. I think the bms would have cut off to save the battery

When you put it back together, put a 5A automotive fuse on the charge port

3 Likes

Plug a charger into the charge port and power it up for a min. When I had some of their gear a long time ago and had a ESC that would constantly short, the BMS would cut off and stop supplying power to the terminals. Plugging the charger into it for 2-3 seconds seemed to “reset” it though. Hopefully that works for you…

1 Like