Mysterious *aka terrifying* VESC fault at full speed

Hi all,

So I’d been out for a half hour ride today, and on my way back i was blasting down a steady, small gradient. I wasn’t at full throttle (I don’t think) but hell I was flying. Anyway I went to apply the brakes, slowly and gently, and they worked for about half a second. Then nothing. I kept gently squeezing the brakes in the hope that the VESC just had a wobble and reset itself, but no, no brakes.

Managed to coast it off a bit and foot brake to safety but jesus my heart leapt!

So I flip the board over to have a look, and there’s no visible damage. No excessive heat, no smell of burning, plus the clear heatshrink round the VESC doesnt even look like it’s warped. Lights on the VESC are as usual, one blue one green. The only fault I can see is whenever i try to give it some throttle or brake, it flashes red three times, twice (six in total)

Walked home, plugged into BLDC, FAULT_CODE_NONE.

Im a bit at a loss here - little bit scared it could happen again. Anyone experienced this? I had a search for threads but can’t find any similar.


What is ur max powered speed and were u above it? At least the throttle will behave like a brake above the no-load speed but don’t remember how throttle is affected

Ok great, managed to go to Realtime data -> Activate Sampling and replicate the throttle issue.

You guessed it: DRV8302!

Ding ding ding we have a winner!

Thanks for you reply man, I have a stinking suspicion I just went above ~60k :weary:

Are brakes affected when going over the no-load speed?

Couldn’t even guess, hopefully someone else can chip in?

FYI I was on a 260kv 8s @ 83mm, ~31mph is no-load max


What Brand of Vesc and which Firmware?

This is how my second 4.12 died. Going downhill, hit the brakes at the end going about 40mph( on my watch said 39), worked for half a second then no brakes. Master died, I foot braked. Coulda been erpm, or overvoltage. Lesson learned, if your making a cruising/downhill combo board, gear it for the speeds you’ll achieve downhill - as erpm doesn’t seem to matter. There’s things like vesc6 which is 150kerpm sure. But two 190kV motors spinning fast enough to be above 60V will still kill all versions of a VESC. So you have to keep your motor speed down.


BLDC 10char

Just a maytech, 4.12 on 2.18 :joy: good job i bought a FOCbox a few weeks ago… buy cheap buy twice!

1 Like

This is something I try hard to share.

Unless your an engineer, and you know how to measure and calculate everything to a tee (and even then, low quality can still bite you), you should over engineer your system. Cheap is never an over engineering (and unusually, is under engineering).

I wasted almost $800 on my first board before I started to buy quality. focbox or chaka vesc are the standard right now.

Well, the Maytech Vesc are not renoun for their quality, also the older one has a bug inside their firmware, that ramp up the current too fast and burn DRV