Nano-x is not working


I got a brand new nano-x that I bought here on the forum and it’s not working. The receiver is blinking in a weird way and not like it’s searching for the remote - it’s blinking slowly and nothing happen when I press the remote. Anyone had this issue?

Thanks, Ishay

Just a stab in the dark - have you made sure that everything is fully charged prior to trying to connect?


Yup, I’ve connected a different remote and it’s working great.

Another daft question, is the plug from the esc in the right way round?


Yup, tried both ways.

Might be best to try and contact Enertion directly and see if they are able to assist. If not, then you’ve just blown a small amount of cash. I don’t suppose that the seller will warrant the goods??

1 Like

Did you tried to bind the remote to the receiver?


I sent him a message, waiting for a reply.

The binding happens automatically on The Nano-x remote.

When I got it I needed to bind it :wink:

1 Like

Really? Seems odd. It flashes fast on the remote and reciever when I turn it on and then the remote flashes steady green and the reciever flashes slowly red.

Try to bind it :wink:


Will do soon as I get home! Thx

HI @Ishayc

Have you tried contacting that person from which you purchased it? Also advise him to contact support with your shipping details need to know if he is eligible for replacement.

1 Like

I’m waiting for his response but I’ll tag him here also - @plantje


If it’s the old model of the nano it needs to be bound

1 Like

The instructions which came with the remote says that the binding happens automatically so it might be the newer model

Charge it.


I did, but I’ll give it another try, thanks!