Nano-X Remote Issues

Did it ever become clear why nano-x wont connect in cold? Mine connect at the same second when board and remote are in room temp, but in 10 celsius it doesn’t. I wonder if i should buy new remote because 10 celsius is warm weather in here. I can’t switch off my board outside because it won’t connect when it’s cooled down. Any idea @onloop

Hi, I had the same problem. Just contact Enertion they should give you a replacement which works, they send me a complete new set of RC an receiver. Now it works flawless.

Did u send remote back to Enertion before they sent you new one? Or did they just sent it after you proved that it doesn’t work?

I didn’t even have to prove it, it was a common manufacturing issue which other people experienced as well so they just send me a new one. It took them 4 month’s though… Their customer service is the worst one I’ve ever encounterd but in the end they come throug though. I would just send them an email and if that does not work send an email to this adres: Linda Stapleton [email protected] she is the bussiness manager there, she got the ball rolling a few times for me when the rest couldn’t do their job. Good luck!

I’ll try that. That 4 months is reason why i’m not very comfy with this. But if i don’t have to send it back before i get new one i’m fine.

Btw did they sent you only receiver or full set?

Its only the older receivers that didn’t work properly. They only need to send the new receiver.

I expected only a new receiver, but instead I got both a new controller and a new receiver.

Yep. Mine is from first batch.

Guys, have anyone had issue where the remote shows ‘binder’ with a solid green, but it doesn’t send any signal out? I have both the new and old receiver and remote, sometimes they connect, sometimes they dont, but no matter how many times I have it connected, it won’t send any signal when I pull the trigger I’m sure the motor is fine because I can run the motor detect perfectly, meaning there is power sending to the motor when I do it through bldc, but the remote has no respond… I’m sure it is connected though, it gave me solid red on receiver and slid green on the remote


The setting are all set back to default configuration, it’s the vesc x from enertion

Are you plugged into channel 1? Most RC receivers use channel 1 for steering. The nano x is built for skateboards specifically. So the primary channel is the throttle. Just asking and hoping to help.

hey there i got signal going now but idk why, when i pull the trigger, it goes full throttle and when i let go of the trigger it just keeps running at 100% and unless that i pull the break, it wont stop when i left the trigger at neutral, it seems to give out 100% throttle im not sure how to configure this XD

so basically the motor only stops when i pull the break completely when i pull the break a bit, it starts to move (as if i pulled the trigger going forward) and by the middle, where it is neutral, it is running at its 100% anything after the middle stays 100%

can anyone tell me how to configure this properly on the bldc XD?

1 Like

what control mode are you running (assuming you’re using the vesc)


Did it just work suddenly or did you find the problem? It may help others to know.

i kept tweaking with the Y connector i had for the dual motors and receiver and it randomly worked… but it was like half an hour of tweaking here and there, not really sure which part exactly did i made it run… but im still stuck on it running at 100% without me pushing the throttle…

1 Like

will try this today!

GUYS IT WORKED great thanks to you all! throttle problem fixed by going into ppm and adjusting the max and min pulsewidth!


btw does anyone know how to switch modes on the nano remote? i see extra buttons on there, how can i configure them so i can have two modes?

The switch that rests under length of your thumb changes the mode from super fucking sensitive to manageable

1 Like