Nano x remote problem!(faulty receiver)

I was trying to bind the receiver to the transmitter and it was working fine. The red light on the receiver was blinking but then when i switched off the esc and turned it back on, the red light wasnt on. I tried

to unplug it and plug it back again and still the red light is off. Can someone pls help me out

Is the fan of the esc still working?

Yh it works

The first time i connected the esc and the receiver it worked but when i now it doesnt and i have know clue why it stopped working


I had a similar issue only mine occurred after pairing then changing some settings on the esc. Then reconnected the receiver and it would not pair.

I disconnected everything, had transmitter off. For 5 minster or so then connected it all back up then powered on the transmitter and it all worked OK after that.

Hopefully this is of help to you…

I tried that but it didnt work. Ive emailed enertion about this because it might be a faulty product, so far they havent returned an email yet @Khaleel

I change the servo wire and soldered a new one but it still didnt work. Im pretty sure this a faulty receiver

If you search “nana x binding” or “nano x issue” you will see a lot of people are having this problem. I think enertion is working on fixing this, whether it involves a recall or a simple solder fix.

I think you need to re calibrate your ESC. I have used these ESCs in a number of builds and without calibration they remain completely unresponsive.

How do you do that? @lowGuido

hold down the red button while it is off and then turn it on, it should go through a series of beeps. the procedure is in the manual. it is states to do this every time you change the transmitter. im fairly sure the purple light lights up when its lost its calibration. I think it should be blue normally… i’ll confirm with one of mine in a few mins.

yes, confirmed. it should light up blue when programmed correctly.

I havent used any other transmitter on my esc other than my nano x(its my first build). And the led is blue not purple.

looks purple in the photo you posted above.

Oh yh😅,its because i only used a 3s lipo to power it up. Here’s a pic when its a 6s lipo

ok, must be a problem with the nano-x then I guess.

Did you try to bend twist the wires connecting the VESC with the receiver? My Nano-x worked fine but then the binding issue appeared from nowhere. Tried everything nothing worked, however, when I touch the cable with my bare hand and bend it a little I the thing binds immediately. When it worked before and with the twist the remote does not take more than 2s to bind.

Seems very temperamental.

It would be interesting to see how many of the purchased Nano-x where faulty from the beginning or failed after a while and how many actually working.

Hey bud, any chances you found a fix? My receiver just did that and now no more red light :confused: