Nano X remote problems

nano x flashes green twice then pauses then flashes twice again when connected to reciever. Never becomes a solid light. When riding it suddenly cuts out. And it’s brand new.

Did you try to rebind it? I suspect you maybe did. If you just bought it then perhaps @carl.1 or @barajabali can help you out. It should be covered under warranty. You should prepare a video of the issue to show them to speed things up.


That sounds like the exact behavior for low battery. Try charging it?


Hey man, shoot me an email at [email protected] I’ll get you a new nano that works.



If you purchased it directly from Enertion then please contact [email protected] with your Order ID

If you purchased it from one of the reseller, then provide the order ID and reseller name.

We will replace it for you


As Jinra said it looks like is low on battery. Please charge it and let us know if it worked :+1:

1 Like

Charged it and still doesn’t work

Just emailed them. BTW the person that created this thread was my bro. It’s my remote but I don’t have my computer or phone with me

Hey um guys why doesn’t my nano x switch between beginner and advanced mode. When I switch, there is no change what so ever

That’s very strange. Both of mine work very well so far. Hope fully @CarlCollins can help you troubleshoot.

@Esk8board4life Aidan, Contact support to get it sorted

1 Like