Nano-x Remote Short Circuit

I recently had to open my nano-x up as the battery wires inside ripped off after an accident. When I got home I plugged it into a charger and the green and red lights both worked and the motor would spin. I then tried testing the battery by touching the wires on the old connection with the wires. Me being me I put the positive wire and the negative wire the wrong way around and now the remote won’t show up with the green light but the red charging light still works.

Any ideas on how to fix this? Or is it beyond repair?


Can you post pictures of the PCB?


Are those three wires, red black and red the battery leads?

No they are the throttle controller.

Can you take a picture of the back side of it.

Could you send pictures of the back where the battery connector is? That is the only way I could tell if there was short circuit protection of some kinda.

@Pantologist @Deak Are these good enough quality?


Looks normal to me. Test your controller battery with multimeter first. If everything is normal then that controller is done.

Battery is working looks like it must be the controller is done :’(

Are you a good solder? Keep your old controller for spare parts. If you want I can send you my old working Nano-X controller. I just got it 3weeks ago with a broken power switch.

I am just waiting for a new replacement Nano-X from Enertion. Because the receiver problem and this broken switch.

Thanks for the offer. Where do you live? Chances are shipping will cost more than it’s worth. I live in New Zealand hahah

France but I am going home to United States next week.

Hi @Deakbannok, if you don’t mind or kptheinventor doesn’t want it, if is possible, I would like to have it. :blush:

I have a winning remote with plenty drops. I hope not been unpolite.

Yeah man that’s fine you can have it :slight_smile: Shipping to New Zealand would cost an arm and a leg. Thanks for all the help guys! I have ordered a benchwheel remote and am now playing the waiting game with that.

1 Like