Need help configuring focbox unity


In my case, it fails on the PC. It has never been successful on a PC. The Android App will succeed. Try it on the Android App.

1 Like

so mine’s dropping ble connection after like 30 seconds.

going to try another device, but so far my unity experience has kinda been shit.

1 Like

Highly recommend a pc for now if your phone is bugging. The app is built on qt at the moment (non-native) and the BLE library it uses doesn’t have the best compatibility with all phones it seems. We are working on native apps for iOS and android but limited resources means slower progress.

1 Like

Ok followed link, see you are having trouble with flux linkage. Can you let me know what your setup is? Belts? Motor kv? If its belts are you doing the hand spin with belts installed on the wheel, it works best that way.

Are both flux linkages not detecting?

1 Like

thanks jeff for the input.

the thing is, connected to PC via usb doesn’t work either, it fails when you go to spin the wheels for flux linkage detection.

o — new post.

yes belts, 6374 190kv motors.

tried both, with belts and spinning the wheel, and also wheels removed, spinning motors by hand.

not sure if both are failing, but i can’t get past the detection.

i think one motor is succeeding.

i’ll keep giving it a go, i’ve got extra motors so i’ll try it with those.

Share back some screenshots of the full app if you can’t get it to pass. Wanna have a look through the parameters it’s reading back.

Sorry for the basic question but you are giving each wheel a nice strong hand spin?

it’s a legit question - i’m giving it everything i’ve got.

i’ll continue messing with it tonight and post results.

thanks again jeff.

I am just going to leave this here :

1 Like

Yeah it shouldn’t really take that much just a nice firm spin. Don’t pull something trying to spin it harder :smile: , check all the bullet solder joints as well.

We’ll get it sorted hopefully its a simple fix.

1 Like

i suspect it’s a problem on my end, not the unity, sorry for mischaracterizing my problem.

maybe i will reflow the solder on all connections.

i’ve tried with hall sensors on and off, could that have an impact?

No the halls won’t effect that portion so don’t worry about those for now.

1 Like

it’s 100% user error.

i was spinning the motor by the shaft. tried spinning the motor by grabbing the can and giving it some torque and it’s reading flux no problems.

this is after trying on three different sets of motors, trying left and right for each, swapping phase wires, with and without hall sensors. turns out i wasn’t grabbing the motor right, so stupid.


Sorry we should do a better job explaining with some tutorial videos.

it’s not you, it’s entirely me lol :smile:

as always, thanks for the help!


just took it out for the first time, first time using a unity.

tested on 6" pnumatics and i just have to say, the brakes are SO NICE.

you’ve gone and completely fixed the braking problem for large diameter wheels on FOC.

good job jeff, you’re gonna get rich doing whatever you’re planning on doing.

1 Like