Need help with Nano-X tx/rx

Doesn’t work on channel 1 or channel 2

Ok. Try rebinding. unplug the power to the VESC, then insert a bind plug. Power it up, then turn on the remote with the button held down. See what happens?

Ok… just make sure that your connection are the same as those (I had make a nice drawing that I don’t want to loose :sweat_smile:), and if you have acces to a multimer make sure that you have 5v on the 5v pin… and if not try to contact enertion support :wink:

Couldn’t post a video but I tried binding it. Still no red light, green light on receiver keeps on switching on/off as it should on binding process. VESC lights are on too.

Checked the connections. Red in middle, black/brown to the left, yellow/orange to the right. No switch between VESC and Rx


I would test the power lines, too. But be CAREFUL. I don’t think the VESC has short protection, so don’t let the multimeter probes slip and short out the pins…

If there are no lights on the receiver, then it is most likely faulty. Will they void warranty if you open the case and have a look at the soldering job? That’d be my first move, anyways.

I am no expert in electronics tbh. Whatever, if it voids warranty I’ll just buy from another company -_-

Looks alright, to be honest. How are the voltages from the VESC? You may have a cold joint at the servo lead on the VESC.

How do I check voltages ?

Do you have a multimeter?

sadly, nope

Hmm… That would be a priority in my case. I have 2, but some people have entire collections.

Does it seem like the receiver is connecting to the remote during binding at all? There might be an RF problem.

Definitely not binding, as I said, there is no red light and the green light on the transmitter keeps beeping

Alright, I’ll just give up at this point. Anybody knows where I can find a good remote (under like 100$) That will ship to Canada-East in under a week?

Where are you located

Quebec city

Just found out that I actually own a multimeter, how do I test it now?

Unplug the connector from the receiver, put your multimeter on the 20V DC scale

with the vesc powered on, red probe on the middle pin of the connector and black probe on the ground. (red on red, black on brown cable)

You should be getting 4.8-5v, but since the receiver’s lights already work that’s probably the case.