Starting Tips | Ask Questions | Introductions | Categories

Nyko Kama VESC settings (too sensitive!) Solved

Hi Everyone!

I i have 2 VESCs connected via CAN BUS and connected to a Nyko Kama nunchuck. All is working well except the throttle / break response is way too sensitive. When i display the input from the Kamas y axis i can see the range of motion from min to max acceleration which is great, but the motors only respond to a small fraction of that full range. Looking at the throttle input on the BLDC screen full motor speed occurs at like 20% input but 15% is dead band, so min to max is only about 5 percent, which is about 1mm of thumb movement. When i break it just comes on full instantly with no proportional respect to throttle position. I’ve had a good look around the settings but can not figure out how to adjust it to make the full throttle range usable. also i have tried using 14 volt input from a supply and with 12S lipo. Throttle response is no different between the two (with respect to minimum and maximum throttle position that is)

Could anyone help me? Thanks!

1 Like

What are your ERPM limits ?
What is your dead band setting ?
Can you post screenshots of the relevant BLDC tool screens ?


Thanks for your reply. I’m not sure how to post a screenshot on this forum? sorry :-/ But the VESCs are from Enertion V4.10 Im using BLDC Tool 2.8 and 2.8 firmware.

Settings under the App configuration > Nunchuck tab

Dead band: 0.15
ERPM limit start: 150000
ERPM limit end: 200000 (but it wont let me adjust higher)

Same settings on both VESCs

@Ross I have this same issue! The throttle and braking when using the nunchuck isn’t smooth or progressive like it when I use GT2B with VESC. The way I’ve tamed it is by limiting RPM so that I don’t end up tripping the voltage cutoff on VESC, but that is a lame solution because the throttle is almost “all or nothing.” This is a part of why I started using GT2B.

Maybe it’s someting to do with your Nyko Kama, is it the same receiver as the one shown in the relevant VESC FAQ thread ?

@trbt555 I have two transmitters that I’ve tried, but only one receiver. Same results either way. I’ll post my screens.

VESC firmware version ?
VESC hardware version ?

@treenutter & @trbt555 Yes its certainly frustrating, especially with 12S! Basically on / off. I don’t believe its a problem with the remote or receiver though because they seem to sending and receiving the correct data. In the BLDC tool display the input bar moves smoothly from full reverse to full forward as it should with respect to the joysticks position. Its just that only the very middle couple of mm either side of neutral (on the controller) is actually useful to modulate the throttle / breaks. On the input display bar you can also see that this is only a very small range around neutral that the motors respond to. And yeah, the break just comes on like an anchor, will lock the wheels even at walking pace.

VESCs are V4.10 and firmware is 2.8

@Ross @trbt555 My VESC is HW version 4.7 and Firmware 2.8. I’m now exclusively using the Linux version of BLDC Tool. BLDC motor control (haven’t tested the nunchuck with FOC yet).

You can adjust the throttle ramping in the app config>nunchuk menu. You also need to know that while running in “current” control the motor will spool up to full rpm if not under any load.

Thanks @chaka. In BLDC 2.8 there are settings for Positive and Negative “ramping time constant” The default settings are .9 and .3 respectively. How will changing these impact control? Would we increase or decrease them to modify sensitivity? I think it would be to increase ramping time to decrease sensitivity. Do you have a sense of how much they should be edited?

Increasing the time will make it feel “softer”

Vedder addressed this here:

1 Like

Thanks @chaka I’ll try these out and report back. I’ll start w 2.0 and 1.0. At some point, someone needs to author a configuration guide for VESC. Maybe it’s a good community project for everyone on this forum!

I adjusted mine to 10 on the positive ramping and though very smooth, it wasn’t quick enough. I was about to try 5 but I shorted out the nunchuck receiver… lol. Picked up a gt2b and it’s way smoother than the nunchuck. It’s huge so I will eventually mod it to a smaller case.

Don’t be afraid to set it higher than 2 on the positive. You may have to give it an initial pushoff though but once you are moving, it’s great.

1 Like

Ramping is really only delaying the problem a little. The problem is that it would still be impossible to hold your thumb at say 35% throttle. you would still basically have to modulate on and off which is a horrible way to control anything! What we need is a “full speed (or) current @ “x” % throttle input” setting. So many people seem to be using the Kama, surely there not all using it like this. Might have to get an RC receiver and use PPM? I really like the Kama, and i know its just a number value somewhere causing the problem!

I gotta ask, have you ridden it yet?

A little yes, but its pretty much unridable… Breaks are certainly useless.

Once you dial back your max current and add a bit of throttle ramping you find it easy to ride at a constant speed.

If you switch to an rc controller aka ppm, you can use duty cycle and have total control but it is much more raw and unregulated.

do you hold down the C button while riding?