Ollin Vesc 1.1 Issues (newly repaired)

I have an Ollin Vesc 1.1 that I just received back from being repaired for a month and a half and it’s not providing power to the motor. Chaka said that I had shorted the PPM cables of the vesc when I sent it in. The vesc is controlled by a servo signal from an arduino nano that takes input from a thumb throttle. The vesc seems to be operating properly with lights turning on when the throttle is applied and throws no faults when checked in terminal. I measured if there was voltage on the output of the vesc and found that when throttle is not applied there is the same voltage between the center pin and the outside cables as the battery voltage. This voltage is unaffected by the throttle when measuring both DC and AC voltage. I tested my motor with another speed controller and it worked fine so a bad motor can’t be the problem. I’d love some help guys!

Have you tried to contact Ollin about the problem? That would be the first step.

The Vesc does not increase voltage as throttle is increased. It allows more current as throttle is increased

1 Like

I feel that your batt max is way to high, basically you have no safety mechanism in place with settings this high (not the cause of your current problem)

image

I’m not to familiar with the ppm setting “current no reverse”, but according to your real time data, you seem to be braking (or is that full throttle?) and the motor is not moving

image

I’m not sure if you PPM window needs to be centered, currently you have it offset. you could try

min ppm: 0.32 max ppm: 2.60

that should center your window with your current ppm output from the arduino. (why do you need an arduino anyways?)

Good eye @Blasto @rocka your absolute max is also too high. Acceptable range according to Vedder is 130-150 Also you have settings for dual Vesc but it appears that your running a single Vesc.

I contacted ollin and this is the response I got.

It also took quite a while to get any response back last time I emailed for help so I posted here first.

1 Like

your screenshot link isn’t working.

First you need to correct your bldc tool settings.

  1. reduce your batt max to 50a
  2. reduce absolute max to 130a
  3. Limit max and min erpm to 60k and -60k
  4. set battery cutoff start and end 22v and 21v
  5. uncheck “send status over can”
  6. uncheck “multiple esc’s over can”
  7. uncheck " enable traction control"
  8. You need to get a successful motor detection, then apply the values and write configuration.

I am not familiar with using an Arduino controller. Most of us use a 2.4ghz ppm controller.

Thank you so much, I’ll try this and post the results here

Have a look though these threads and maybe you can find some help with the Arduino

2 Likes

I did everything you said and didn’t get any change. the motor is till not spinning and i’m not getting a detection. The arduino should not have any effect on the system as it worked fine before the fault and only outputs a servo signal to the ppm port of the vesc, the signal is even registering on the bldc tool

i believe that is showing that throttle is at 100%. I don’t think PPM should be centered because i’m using current no reverse as as my control type. i’m using an arduino because I wanted to add other functionality such as cruise control, different power modes, and light toggles.

You have to get a successful motor detection befor dealing with the controller. Is your motor disconnected from the drive train while performing motor detection?

PPM should always be centered, even when you’re not using reverse. That could be a large part of the problem here.

1 Like

The motor is connected to the vesc but the output shaft is not connected a belt or any drive train when I’m doing the detection. The motor also isn’t making any sound and I can’t feel any movement.

I had this working fine before with the ppm set like that. but I will go ahead and change the setting so it is centered when throttle in its resting position to see if it works

Are you using a sensored motor? If yes, try disconnecting the sensor cable and do detection without the sensors

I would set to No App, reboot, try detection then

1 Like

i’m running the sk3 sensorless

what size and KV and are you running 6s.

just tried it. motor doesn’t spin and its saying that the detection failed. but the vesc did blink green for a second

Does the motor turn freely by hand