Starting Tips | Ask Questions | Introductions | Categories

One R-Spec motor hotter than the other [solved]

After an extended test run today I noticed one of my motor was hotter than the other.
And after a bit of testing I also noticed that the same motor doesn’t spin as long after releasing the throttle from full and is noticeably harder to turn by hand.

So hence my question, what could be the problem and what can I do to fix it?
Could the bearings be the problem?

Edit: Quick video:

First, rule out the VESC by switching the phase wires between motors. If the problem persists on the same side, the problem is mechanical, then somehow the motor must be encountering friction.
Check if your pulley isn’t rubbing against the mount.
Take them both out of the mount and nd try to turn the spindle, if one has more friction than the other one, there may be a problem sith a bearing. I’ve never taken a motor apart so I can’t help with that. Perhaps someone who has, can commment on how to check the bearings.

I’m pretty sure it’s not vesc related, since it’s harder to turn by hand when the power is off.
And the pulleys were clear of the mount as well, but removed them anyway.

So without anything attached to the axles it’s still the same resault.
Not sure i wanna pull it apart without a go-ahead from @onloop @carl.1

I would first follow what @trbt said and switch the motors to the other VESC.

You said there was still friction when the motor wasn’t attached to anything:
-does it feel like intensified magnetic resistance (like if two of the phase wires were just barely touching)
-or does it feel like a physical resistance such as a blew out bearing?

We haven’t ever had a bearing go on any of our motors, so our first assumption is that this is either a VESC related issue or possible two phase wires touching. Even if it isn’t a VESC issue, the live data tab of the BLDC tool should be able to give you a slight indication that the motor isn’t performing 100%

The phase wire touching could also have occurred where the motor wires go into the R-SPEC, as one strand of copper could be touching a different phase wire creating some resistance. Although we haven’t seen this issue before, it (like anything else) is still a possibility.

Hmm, might be magnetic, since there’s no scraping sound or anything when turning the motor by hand.
I’ll do a closer inspection of the connections and try with the other vesc, then report back.

Too much tension on one of the pulleys?

1 Like

This is the realtime plot of the problematic motor:

And this is the normal one.

Also tried switching them around between the vescs, the same motor slows down considerably faster still. And it gets warm to the touch with the small amount testing i did while the normal motor is still cold. And even when the motor is disconnected from everything it still is sluggish.

Starting to suspect there’s something inside the motor that’s not quite right. I could open it up and get you some pictures of the innards if you want. I might even be able to spot the problem myself.

Just gonna post stuff that I would check right off the back even if you’ve already tried it lol

Make sure nuts aren’t tightened too much on the wheel
Belts have a little slack in them
Remove belts and see if the resistance is from the motor itself or the wheel
Check connecting phase wires

Disconnect vesc and see if resistance is still around
Make sure the motor doesn’t have physical damage to it

Unfortunately this game is pay to play as we all know lol sometimes we just need replacements
I have had this issue before with an E sc but it wasn’t a VESc basically it was just fried. When I dissconectrd the esc motor turned fine

Already went through that stuff, eliminated the escs and drivetrain as a problem source.
One motor is harder to turn than the other while disconnected from everything.
I’m just hoping it’s an easy fix, otherwise i’d propably have to send it in for repair.

If the motor’s shorted it will have more resistance either with power or not. Sounds like a partial short.

The resistance difference between phases is probably almost the same and so low a multimeter isn’t accurate enough to reveal a short. An LC meter will tell you using the inductance tool. More accurate but u likely don’t have one. 30$ on eBay.

Man up and rewind it!!

Just make sure u don’t damage the insulation on the stator on the unwind or you’ll have an awful time with it. …as I have. LRK wind is ideal for its ease to rewind on just every other tooth and better for longer torque motors as yours kind of is. Finally almost done both. Doing it now

1 Like

will you post some pics of the inside of the motor (without taking it apart)?

Just take it off the mount, and have one pic from the front, and one from the back.

As @Hummie said it may be a partial short, where two parts of the phase wires are touching together when they aren’t supposed to be. It could be as simple as pulling the two little strands away form each other, and then having it fixed!

it could also be shorting through the stator or the bearing tube. If you have a multimeter see if you can get a circuit through each wire and the stator or the bearing tube. Radio shack has them for 20$. Harbor freight has them for free with a coupon!!

If it’s a partial short it’ll be in a winding on a tooth and more minor. If it were shorting through the main phases I think you will get very hot quickly and the motor will really suck. Yours sounds minor and a partial short. I doubt visually it will show.
See if u can isolate every wire from each other as best as possible and also from the bearing tube and try it then. Maybe through vibration and rubbing insulation from wires has been removed.

1 Like

Can’t really see much from the outside, except for one strand that’s a bit off. Tried to cover as many angles as possible. Sorry about the dust. Uploading…

upon closer inspection of that runaway strand, it seems to cross at least one other group of strands. The right ring is where i originally found it, the left one is the same one, it continues in an odd way further in, but couldn’t get a good pic of it.

Did some additional testing with a multimeter, seems that all three phase wires are connecting with the whatsitsname.
(The left one is the troublemaker btw)

1 Like

Did some more poking around with the multimeter, some insulation has indeed come off some of the strands just after where the wires enter the motor.
Should i open it up and see if i can insulate them with something?
Because if that’s all there is it shouldn’t be too hard to fix, depending on how the wires are to work with.

Don’t open the motor up just yet.

It is clear that there is a short, but the good news seems to be that it isn’t terribly bad, and your VESC doesn’t seem to have been damaged either.

I’m starting to think it may be because of the extreme motor wire angles on your deck. Could at full turning it be pulling the wires at a less-than-ideal angle? Just turning back and forth with the bend occuring at the motor entry point could have wiggles a copper strand loose.

Maybe change your R-SPEC’s to face the other direction, and route the wires around next to your truck. This is what we do on our Raptors. You could also embed the wires into the deck or truck riser as @longhairedboy (embedded into the deck) or @cmatson (through the risers) have done.

All this said, I don’t want you to open it up at this time, and risk damaging the motor further. You could send it back (just submit an RA on our website as the motor should not have died that quickly), but if you feel confident enough to fix the problem yourself we may be able to work something out.

I thought the wires were fastened somehow in the can, but now that you mention it, when i turn the trucks i see an ever so slight wiggle in the wires inside. Guess that could be the cause of it.

I can rotate the motors and see how that works.

I’d rather not have to send it over to you, seeing as shipping and import duties will start to add up.

I’ve got fairly good skills with opening up and fixing stuff, and seeing the way it is assembled, it doesn’t look all that advaced, and i’m pretty confident i can at least open it and close it without damage.
And once open i can judge if it’s something i can fix or not.
Just popping the can shouldn’t damage any of the windings if i’m careful.

But i leave the final say to you, if you want me to send it back, i’ll do it, no problem.
I can do monodrive for a while if need be.

If you are happy to proceed with opening the motor please go for it, the motor is fairly simple and should be easy to open with the correct tools and a logical approach.

I have discussed this matter with the motor factory and they suggest simply gluing the wires back onto the bundle should resolve the issues.

epoxy or some other durable heat resistant glue would work.

if you get stuck please post photos on this forum showing how you did it. Actually, if you don’t get stuck maybe posting the photos of your work might help others in the future.

I’ll get cracking later today, got some high heat silicone I could coat the wires with.
Will just have to see if I can get enough of the cables out to work with them.

If not I’ll let you know.