Only one motor working

Hi guys does anyone know what I’m missing I have the can bus connector, I tried the other motor it works fine by it self. Also how do I connect the sensor wiresIMG_20180803_180033

little more info my friend and some pics of set up

1 Like

I posted the picture


This is where your sensors plug in.
I can’t see anything obviously wrong

That’s the picture now the info.

Has it ever worked or is this the first time you’ve powered up?

Btw. important do not disconnect the canbus while the board is powered up ever!! Good idea to hot glue the connectors in.

If I connect the motors seperatly they work fine. I just can’t get them to both work at the same time. Do I need to program the vescs?

have you ever programmed the VESCs? it’s not exactly plug and play

You have to set one as the Master “ID=0”(the one with the receiver on the bottom of pix), send command over canbus and the other would be set as slave “ID=1” and receive command over canbus

1 Like

15334125242613369436428275757619 Ok thanks I’m trying to connect but I keep on getting this any ideas?

Watch this quick video and all will be revealed!!

1 Like

1.) obviously, first make sure your usb cable is plugged in 2.) make sure your port com # is the correct one, that should be on the left panel, under connection, click on the down and check the other COMs