Over 300A spikes and -100A spikes on the phases (ABS_OVER_CURRENT)

So I’ve got this problem with my VESCs. If I do a hard acceleration or if the motor needs to do a bigger push, the vesc reboots. After hooking it up to a pc and checking fault codes I get a ABS_OVER_CURRENT for a second and then it the error disappear. The biggest problem is, when this happens the board turn off and I (nearly) goes flying of. I have tried updating the firmware, adding bigger caps, shorten the wires, removing all bullet-connectors and lowered all motor/battery settings. But nothing changes :frowning: The VESC I’m using is the Flipsky Vesc 4.20 from banggood ( https://www.banggood.com/HGLRC-Flipsky-Mini-FSESC4_20-50A-ESC-Based-Upon-VESC-With-Aluminum-Anodized-Heat-Sink-for-Rc-Car-p-1349277.html?rmmds=search&cur_warehouse=CN)

It’s probably the design of the vesc that causes this I would assume, but are there anything you might suspect why this is happening?



I have looked everywhere but haven’t found anything about these kind of huge current spikes

You should put more info (motor, battery, configuration); by the other hand…RC esc to run a board at 50A motor max, and 50 of break…I would by another Esc more capable to manage sudden acceleration, like FocBox, Vesc 6. I also will try setting 35A motor max, 30 motor break, 150 absolute current…If thats works good, it might be time to buy a better Vesc to handle those currents. Wish you the best…


I’ve tried running it on a higher absolute and super low motor/battery settings, down to 20A but still the same :confused:

it might just be the 4.20 actually

what voltage are you running your build at?

That is what I’m starting to think too. I’m running 10s

keeps the batt max normal and try to increase your motor max but no higher than 30a and see what happens

**ps dont eat street

I tried batt max 15A, motor max 20A/-20A but still the same :confused:

up the battery max

15a is low

also what battery you got?

i have zippy 5ah 20c LiPo’s Still no luck :frowning:

voltage? how many volts is it?

it’s 10s, so 42v charged

Check if your main capacitors leg broke from vibration? Could be this or some other error in reading currents.

Did you use it a while before this issue arose or did it do that from the start?

1 Like

Looks like the same hardware?

1 Like

Thank you so much @linsus for shearing the post! I’m gonna test the fix tomorrow and it should work. It have been confirmed by Flipsky that the problem was as described in the post :smiley:

No problem bro, surprised noone of the others didnt already :slight_smile: