PPM App Configuration - Deadband/Pulsewidth

So I was curious about the PPM App Configuration, I hadn’t changed any of the settings and I figured it wouldn’t hurt to customize these values for my own build. What I did and How it changed my Board:

  1. Changed the deadband from .15 to .05

  2. Changed the minimum pulse width to 1.09 from 1.00. Did this because earn my controller was at full brake, I was only getting about 9% Pulsewidth

  3. Changed maximum Pulsewidth to 1.96 from 2.00. Also, because when I was at full throttle I was only getting 94% pulse

1st issue: when the controller was turned off, the pulse width was changed to 55%, which gave it a little acceleration. Fixed this by changing the trim on my gt2b and adjusting the min and max to keep it at 50% Pulsewidth

What this changed, it increased my acceleration and my top speed, this also gave me stronger brakes.

your deadband is to low, the ppm is always a little noisy varying ±0.1 ms. If your deadband window is to narrow and your signal is not perfectly centered, you will get some funky accelerating or braking. The dead band is centered on the center (min+max)/2.

meaning if you have a dead band of 0.05ms, it’s only 0.025ms away from accelerating

1 Like

Yeah, sorry if I didn’t make it clear. I fixed the acceleration issue, while still keeping deadband at .05. No issues so far