PPM Setup Problems With Hobbyking VESC And GT2B


I’m trying to set up a hobbyking VESC with a GT2B receiver. The motor setup was fine, but no data is coming through for the ppm setup. I have enabled live data but when I click apply it says failed applying pulse lengths. The receiver seems to be connecting to the tx because when I turn that off the signal light flashes.

Has anyone else encountered this issue?

Kind regards,


Are you plugged into the correct channel? I believe it’s 2 for acceleration and brake

1 Like

The signal is on a Servo connector with the Vcc so I only have one option for channel. I tried a servo in channel 3 and it made a noise when I moved the wheel on the tx so it must be connected, but when I put it in channel 1 or 2 it doesn’t respond to any control so I don’t think those connect to the throttle.

I’m using the tool downloaded from the VESC project website if that helps

Hmm, not sure what would be wrong if it isn’t working on channel 2 :confused:

I just remembered that Rx is common power rail so I’ll try again later with the VESC on 2 instead of the servo :slight_smile:

1 Like

That worked, thanks

1 Like

glad it worked out for you

1 Like