Problems with bluetooth module

Hi guys,

I’m having some problems with my Bluetooth module. First, it didn’t work at all but I guess that was because I was configuring my vesc with the VESC-tool, instead of ackmaniacs version.

So I got his version and out of the blue it worked, I was really surprised. But then I ran motor detection and configured my remote using the new ackmaniac vesc tool and the Bluetooth module stopped working. It doesn’t send out any data but is connected.

It says ‘ESC is not connected’

Anyone know how I can fix this? Thanks in advance

  • Flim

Go back to your ppm settings and select ppm+uart, than double check the baudrate is 9600 and all should be good again


It is already set like this.

But now I get the error Status: Invalid serial port: \.\COM4, too

so you can’t connect to the VESC?

You get this fault in the vesc tool? Than your Computer tried to connect to the vesc via bt. Switch off bt on your computer and connect again

Yes in vesc tool.

BT wasn’t even on… :confused: double checked it ticked the boxes on and off.

It’s defintaley off now but still not working

Switch off vesc Close vesc tool Restart everything again

working now. Thanks Andy! <3

1 Like

Welcome! One solution for me please :stuck_out_tongue_winking_eye:


good you got it working guys :grin: , this is the time to say that ironic phrase everyone hates “have you tried turning it on and off again?”

I feel that sellers should really list setting the baudrate to 9600, because currently nobody does.

1 Like

Oh that wasn’t actually the problem. I kept ticking the box to ppm and uart but it didn’t save. Had to click some button that would save it

Damn, XD

10 char