Programming SK8 VESC on MacBook via USB C

Ok so I have pretty good knowledge with reg esc and electronic programming on my MacBook such as betaflight. But I have not been able to find the download to program my Vesc on my MacBook. Also what software do you recommend I use for them, I am running Hobbyking SK8 VESC with the SK8 6374 149kv motors on 12s with an AT setup. I appreciate any help I can get just can’t find much on this. FYI I want to have good torque and top speed.

There are osx builds Available in the vesc tool thread here, though not official and maybe not the latest.

The windows version also works with parallels or bootcamp where the former is actually the easiest solution. Not going to explain how to use it, plenty of info online. In my opinion it’s self explanatory.

Last step, USB-c to USB adapter.

So is there no legit OS X tools for vesc so would it be better to just do it on windows, if so what protocol works the best with the hobby king vesc

Ackmaniac’s version of the vesc tool or the official firmware at Personal preference. Ackmaniac’s firmware offers better failsafe and has watt control, but imo it’s a bit more complex to setup.

I personally haven’t had issues with

Which is the unofficial osx build of the vesc tool. Been updated 3 days ago so it’s most likely the most recent version of the vesc tool.

Is that the link for Ackmaniac’s version

No, vesc tool.

Ok do you have a link for ackmaniacs version then

Dunno if there is one. Search his thread for the typical terms…osx/mac

I can’t seem to get the software (or perhaps hardware) to connect, all is switched on, and it runs through all the possible connections, then acts as if there is nothing there. I suspect the USB C adapter, of which I have tried two. Anyone having trouble like this?

Same issue here. It worked for a time, than nothing. VESCs are still recognised with a PC under Win10.

Haven’t connected it yet using a touchbar MBP or USB-C type connection, so can’t tell if the adapter might be to blame or not. You can at least check if the vesc is unrecognized.

Typical failure is also a cable that is too fat and doesn’t go all the way in vesc side. Get a knife and cut off as much plastic of the connector as you can.