R-Spec - given up the ghost? [FIXED]

Forgive the play on words!

I’ve had a hunt around but can’t find a similar issue though it must be a fairly common I’d imagine.

Any ideas what might have given my motor the jitters? It would be fair to say I’m not the most gentle lover and she really does need a good clean but today my motor slowly ground to a halt (the accelerator started breaking rather than accelerating) and now I get the following horrific cogging.

Did I break it? I can’t see any broken wires etc, could this just be an ingress of dirt issue is is it likely something more serious? OR could it be an electrical issue? I have another FOCBOX to try but it would need different connectors soldering on so I thought I’d ask you awesome folk before I got my tip warm!

Any help HUGELY appreciated :flushed:

hah… actually nice play with the words considering the new motor name :wink:

Well… I have only 2 ‘guesses’·.

  1. Something with your settings is not alright

  2. Something has stuck into the stator and with motion your motor (the can) needs to skip over this obstacle, so it might as well cause the ‘jitter’·.

To be honest I once caught up metal shavings when i placed motor on the table… it was so bad that when turning the motor by hand it stuck at one point… and onwards rotated smoothly in only one direction, otherwise it got stuck (stopped) completely again (if turned opposite direction)…

I would advise to check whenever it is ‘easy’ to turn the motor by hand… or do you feel some sort of ‘shakes’ or ‘rubbles’ when turning it (not smooth) ?

1 Like

Hey thanks for the quick reply! So turning the wheel by hand (and rolling it along my forearm) feels exactly the same as it usually would - it doesn’t feel gritty or obstructed in any way. It actually happened when riding from a smooth cycle path to more bumpy paving and literally started decelerating at that moment. I guess the jolt could have interfered with my electronics somehow? Could that provide this result?

Since turning it manually by hand is normal, I agree with @Okami; looks like something odd with your settings. I’d re-run motor detection and see if that fixes it. I’d be curious if and how much your values change. Just don’t forget that you need to remove the load from the motor (belt and ideally the pulley as well) to run detection.

1 Like

Thanks @rpn314 - so I just ran motor detection and the result was similar to the controller:

Cogging hell :scream:

you may have a short either in your phase leads or in the windings. Continuing to run motor detection with a short in the phase leads could potentially kill your VESC.

Its also possible that you have a connection break, meaning the power isn’t going through one of the phases as it should. If you feel comfortable removing the motor and can you might want to do that to look for tiny breaks in the windings.


I would have run detection after taking off the wheel and belt (and ideally pulley as well, so it’s just the shaft left), but @longhairedboy speaks the truth.

1 Like

Hey man, had the exact same problem. I figured that one of the phase wires coming from my motor were mangled and it disturbed with motor detection. I resoldered the wires and it was fine afterwards.

1 Like


Thanks man - appreciate the guidance. I’ll strip it down at the weekend and report back. Sorry @rpn314 I see what you mean now by reducing the load! Whoops, that would have made sense!

1 Like

AHA! That’d make sense…and pretty resuring that it might be salvageable. I guess the proof is in the pudding. I’ll do a bit of research on how to get her clothes off and report back :wink:

id like to say i found the same issue with bent phase wires… just had to snip and redo them…


Quick question always wondered - what real world difference would you see if motor detection had been done with/without a pulley+belt? Or is it just a case of ‘nothing-really-but-its-best-practice’?

1 Like

I’ll run a test tonight and tell you :slight_smile: Vauge recollection of other’s experiences tells me that even just the pulley makes a difference of about 100 BEMF.


Hey folks!

So I tried the motor with a fresh vesc and had the same result so it has to be the motor.

I’ve managed to disassemble it right to the final stages but it looks as though it’s glued together??? I’ve been through this thread and can see it can be a bit of a beast to get apart but this is ridiculous! Before I try to go any further can anyone see anything obvious that might be causing the issue??

Any help hugely appreciated.

So, I just had a closer look this morning and I think I’ve found the issue - a couple of wires have broken and look to have shorted against another phase wire - can this just happen if they touch? The shrink wrap isn’t long enough currently to prevent this. It’s tricky to photograph but…

Tried to remove the stator again but it’s completely glued on so gonna try and just solder the broken wires and add longer shrink tubing to ensure they don’t touch again and give it a whirl. Hopefuly this will cure the issue?



1 Like


Guess the phase wires touching is bad juju! She does sound a little gruff but then I have been man handling the crap out of her - maybe a bit of lube will sweeten things up? This is starting to sound a little bit to much like a blue movie! :stuck_out_tongue_winking_eye:

Thank you everyone so much for your help - you my friends are legends :kissing_heart:


just got here because of your other post. I’m not looking forward to the day I would have to do this…interestingly, this thread looks just like you talking to yourself. Glad you shared


Ha thanks. Yeah it was a bit of a tricky job, but I learnt quite a lot and the sense of achievement in reviving it from the dead was well worth it - plus it saved me $$$! I reckon if I have to do it again it’ll actually be quite a quick job, it’s just having the balls to do it - I wouldn’t do it for fun though! :laughing:

LHB, i have a similar problem with the motor cogging at acceleration (after the board in motion). It cogs randomly and seems to go away for minutes only to come back again. Is likely that I traumatized my dear motor by riding it with loose screws over rough roads for a few miles? It was working just fine prior to this abusive episode.

Very helpful thread. Thanks for sharing.

1 Like